Closed Bug 1192061 Opened 5 years ago Closed 4 years ago

SVG images attachments do not display inline

Categories

(MailNews Core :: MIME, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 44.0

People

(Reporter: lidl, Assigned: mkmelin)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/44.0.2403.125 Safari/537.36

Steps to reproduce:

I get various web comics mailed to me every day.  The files are sent as mime
attachments.  Some are gif, some are jpeg, some are png.  These display inline properly.

Last month, one of them switched to svg.  These do not display, and must
be spawned in an external viewer.


Actual results:

Image did not display inline.


Expected results:

The SVG image should have displayed inline, like the jpeg, png and gif images do.
Thanks and yes, that's obviously a nice and logical enhancement request.
Status: UNCONFIRMED → NEW
Component: Untriaged → MIME
Ever confirmed: true
Product: Thunderbird → MailNews Core
Severity: normal → enhancement
Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Attachment #8657310 - Flags: review?(squibblyflabbetydoo)
Comment on attachment 8657310 [details] [diff] [review]
bug1192061_svg_inline.patch

Review of attachment 8657310 [details] [diff] [review]:
-----------------------------------------------------------------

rs=me. I didn't apply this patch, but it seems sane to me.
Attachment #8657310 - Flags: review?(squibblyflabbetydoo) → review+
https://hg.mozilla.org/comm-central/rev/6ef146c0c1b3 -> FIXED
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 44.0
You need to log in before you can comment on or make changes to this bug.