Pointer position is incorrect when drag window to screen with different DPI

RESOLVED DUPLICATE of bug 1189565

Status

()

Core
Widget: Cocoa
RESOLVED DUPLICATE of bug 1189565
3 years ago
3 years ago

People

(Reporter: xidorn, Unassigned)

Tracking

({regression})

Trunk
x86_64
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(firefox42 affected)

Details

Steps to reproduce:
1. open a window in one screen
2. drag it to another screen which has a different dpi (either from lo-dpi to hi-dpi or reverse)

Expected result:
everything works fine as if the window was initially opened in the target screen

Actual result:
the scale of pointer position seems to remain in the previous screen, which makes the position of the cursor doesn't match where it interacts with the UI. e.g. when from hi-dpi to lo-dpi, you can see the I-beam for the address bar on a far lower place.

This seems to be a very recent regression. I didn't see this issue in aurora, neither in the nightly several days ago.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1189565
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.