Closed Bug 1192119 Opened 6 years ago Closed 6 years ago

Context menu item text is misaligned

Categories

(Firefox :: Menus, defect)

42 Branch
x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1201318

People

(Reporter: okdana+bugzilla, Unassigned)

Details

Attachments

(2 files)

327.96 KB, video/mp4
Details
79.80 KB, image/png
Details
Attached video menu.mp4
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150806004006

Steps to reproduce:

I have been running Aurora on my retina MBP with OS X 10.11 (El Capitan) since Developer Beta 4. Immediately after upgrading to Developer Beta 5, i discovered that a new bug has appeared: The text in Firefox's context menu items are vertically misaligned, so that the text appears at the very top of the containing menu-item element rather than in the middle.

Since i never had this bug with DB4, and i encountered it immediately after upgrading to DB5, i assume this was triggered by something on Apple's side. But i thought i should report it anyway.

I've attached a video showing what the issue looks like in Firefox 42 (Nightly is affected in addition to Aurora). It's especially noticeable in the hover state. The non-textual menu items (the ones with the back/forward/refresh icons) don't seem to be affected.

The video also shows a 'flicker' problem that i reported in bug # 1187680, which is presumably not relevant — however, i attached a similar video to that bug when i was on DB4 which shows how the text previously appeared, if that's useful for reference.

1. Right-click anywhere in Firefox
2. Note vertical alignment of menu item text


Actual results:

Text is misaligned


Expected results:

Text should be vertically centred
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86
Component: Untriaged → Menus
Attached image comparison.png
Bug # 1187680 has been resolved, but this alignment issue persists in Firefox 42.0a2 (2015-09-19) on OS X 10.11 GM.

See attached comparison between an original OS X context menu and a Firefox one.
Adjusting the padding seems to help. At first glance this appears to make the text match the OS X menus:

menu, menuitem, menucaption {
	padding-top:    3px !important;
	padding-bottom: 1px !important;
}

However, it also messes up the alignment on iconic menu items (back, forward, refresh, book-mark). Maybe those just need adjusted back up.
The correct padding should be coming from the text itself. However, the text has a broken font, so its metrics are all off. Once it has the correct font, the alignment will be correct again.
Fixing the font is happening in bug 1201318.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1201318
You need to log in before you can comment on or make changes to this bug.