Firefox 39.0.3 release notes page doesn't provide a link to download Firefox 39.0.3

RESOLVED DUPLICATE of bug 939470

Status

www.mozilla.org
Pages & Content
--
major
RESOLVED DUPLICATE of bug 939470
3 years ago
3 years ago

People

(Reporter: Steve Chessin, Unassigned)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150630154324

Steps to reproduce:

I got a Software Update telling me that Firefox 39.0.3 was available. Since I never update-in-place, I clicked on the link that said "View more information about this update". That took me to:
https://www.mozilla.org/en-US/firefox/39.0.3/releasenotes/
From there, I clicked on "Download", and that took me to:
https://www.mozilla.org/en-US/firefox/new/

That page said " Congrats! You’re using the latest version of Firefox." I'm used to that lie (when are you going to fix that?), so I ignored it and clicked on the link that said "Download a fresh copy". That took me to:
https://www.mozilla.org/en-US/firefox/all/
but all the links there were for Firefox 39.0, not Firefox 39.0.3. Just to convince myself, I clicked on the link for English(US) Mac, and it downloaded a file called "Firefox 39.0.dmg" which compared exactly to the same-named file I had downloaded on July 3rd.


Actual results:

It took me to Firefox 39.0.


Expected results:

It should have taken me to Firefox 39.0.3.
(Reporter)

Updated

3 years ago
Severity: normal → major
Component: Untriaged → Pages & Content
Product: Firefox → www.mozilla.org
Version: 39 Branch → Production
Yes, it's a known issue. I'm about to solve it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 939470
You need to log in before you can comment on or make changes to this bug.