Closed Bug 1192187 Opened 5 years ago Closed 3 years ago

[Aries KK][Dialer] DUT does not ring for incoming call after connect to bluetooth headset; ringer is heard from headset though

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(b2g-v2.2 unaffected, b2g-master affected)

RESOLVED WONTFIX
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- affected

People

(Reporter: yelanying, Unassigned)

References

Details

(Whiteboard: [2.5-aries-test-run-1])

Attachments

(3 files)

Attached video Aries_KK v2.5.3gp
[1.Description]:
[Aries KK v2.5][Dialer]  Make the DUTconnected with bluetooth headsets. It dosen't have voice but vibrate only when a call is coming.
Time: 16:49
See attachments logcat_1649.txt and Aries_KK v2.5.3gp

[2.Testing Steps]: 
Precondition:
You haven't been using dialer app before connecting bluetooth headsets.
1.Launch settings app.
2.Turn on bluetooth, and connect with bluetooth headsets.
3.Launch Dialer and make out a call.
4.After hung up the call in step 3, MT a call.

[3.Expected Result]: 
4.It has sound and vibrate both.

[4.Actual Result]: 
4.It dosen't have voice but vibrate only .

[5.Reproduction build]: 
Device: Aries KK 2.5(Affected)
Build ID               20150806003241
Gaia Revision          581de383687dc441a878d2c91a0167c6ec688fef
Gaia Date              2015-08-05 01:48:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/9801f91760d9
Gecko Version          42.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150805.235801
Firmware Date          Wed Aug  5 23:58:08 UTC 2015
Bootloader             s1

Device: Flame KK 2.2(Unaffected)
Build ID               20150806032503

Gaia Revision          f8b119ac30e97df991c97682ac4d4f9ca22e1793

Gaia Date              2015-07-31 13:20:55

Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a9379f716e9f

Gecko Version          37.0

Device Name            flame

Firmware(Release)      4.4.2

Firmware(Incremental)  eng.cltbld.20150806.065240

Firmware Date          Thu Aug  6 06:52:51 EDT 2015

Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK v2.5(Unaffected):
Build ID               20150806103226
Gaia Revision          497fe3f938722b0aa49c93f975fad5d9ed3b0a82
Gaia Date              2015-08-06 05:30:02
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/2fad09a0540d
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150806.135403
Firmware Date          Thu Aug  6 13:54:17 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
Free test
Attached file logcat_1649.txt
[Blocking Requested - why for this release]: Functional regression.
blocking-b2g: --- → 2.5?
blocking-b2g: 2.5? → 2.5+
I wasn't able to reproduce this issue on the latest available Aries build.  Leaving the work tags so someone else can try.

Actual Results:  The user had voice and audio when using the headset.

Environmental Variables:
Device: Aries 2.5
BuildID: 20150806201613
Gaia: 497fe3f938722b0aa49c93f975fad5d9ed3b0a82
Gecko: 9bdbdad287e0
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
Flags: needinfo?(ktucker)
Flags: needinfo?(ktucker)
Hi Jayme,

This bug still can be repro on the latest Aries KK v2.5 by the STR of Comment 0. Please note the precondition: "You haven't been using dialer app before connecting bluetooth headsets." and this bug occured at 01:08 in video "Aries_KK v2.5.3gp" . Could you help to try again ? Thank you very much.
Flags: needinfo?(jmercado)
Jessica,

I looked into this issue and also the attached video at comment 0, and I *think* you're talking about the phone itself doesn't ring for incoming call with bluetooth headset connected, and not anything related to bluetooth headset not having 'voice' after answering call. Could you confirm the bug and maybe elaborate more on bug behavior?
Flags: needinfo?(jmercado) → needinfo?(yelanying)
Hi Pi Wei,
This bug behavior is that user can't hear ringtone sound of incoming call from phone speaker, but can hear it from bluetooth headset. Hope helps. Thank you very much.
Flags: needinfo?(yelanying) → needinfo?(pcheng)
Thanks for confirming. Changing title to better reflect bug behavior. According to bug report, this issue is specific to Aries. We need to confirm this is a regression on Aries before attempting the window.

QA-Wanted to check on an early Aries build on whether the bug occurs there.
Flags: needinfo?(pcheng)
Summary: [Aries KK][Dialer] It dosen't have voice but vibrate only when using bluetooth headsets. → [Aries KK][Dialer] DUT does not ring for incoming call after connect to bluetooth headset; ringer is heard from headset though
Confirmed it's a regression within Aries. The issue does not reproduce on the following build:

Device: Aries
BuildID: 20150516110322
Gaia: 4c0f36e9dfe017bf2a698d416a57c8156b43383d
Gecko: 0273e9c967ec
Gonk: 3af1ede0d0956cfbf9c549df7cd9a6807a9efdf2
Version: 41.0a1 (2.5 Master) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Working on getting the window.
Flags: needinfo?(jmercado)
QA Contact: pcheng
Flags: needinfo?(jmercado)
I actually cannot reproduce this issue on today's build. Tried three times with factory resetting DUT between each attempt and can't repro. Incoming call rings on DUT loudspeaker.

Bug does not reproduce with this build:

Device: Aries 2.5
BuildID: 20150817141354
Gaia: 60489c1ff8c5d1633fc4837d4f8019623d4e1940
Gecko: a6eeb28458fd2652e12e57334f046b7776d75bb4
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

-----

Jessica, could you confirm whether the bug still repro's on latest?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(yelanying)
Flags: needinfo?(jmercado)
Jessica can you try this on the latest Aries build and see if you can reproduce.
Flags: needinfo?(jmercado)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Hi Pi Wei & Jayme,

The bug still can be reproduced on the latest Aries KK v2.5.  The key of this bug is the precondition of comment 0,  and don't adjust the volume before launching dialer app.

See attachment: verified_Aries KK v2.5.3gp. 

Thank you.
Flags: needinfo?(yelanying) → needinfo?(jmercado)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+], [MGSEI-Triage+]
Pi Wei, can you try this one more time please?
Flags: needinfo?(jmercado) → needinfo?(pcheng)
I did follow the precondition. I looked into this further and found out that I had missed doing step 3 of STR (I didn't make a call first). With this specific step, I can now repro this issue on today's build, as well as on earliest Aries build we have available on 5/16. Which means this is not a regression.
QA Whiteboard: [QAnalyst-Triage+], [MGSEI-Triage+] → [QAnalyst-Triage?], [MGSEI-Triage+]
Flags: needinfo?(pcheng) → needinfo?(jmercado)
QA Whiteboard: [QAnalyst-Triage?], [MGSEI-Triage+] → [QAnalyst-Triage+], [MGSEI-Triage+]
Flags: needinfo?(jmercado)
[Blocking Requested - why for this release]:Renominating for 2.5. Need expected behavior. 

UX Team/Wilfred, Can you please confirm the desired behavior here?

Thanks
blocking-b2g: 2.5+ → 2.5?
Flags: needinfo?(wmathanaraj)
Flags: needinfo?(firefoxos-ux-bugzilla)
Please see bug # 1182784. Issues look similar
From UX triage:

Agree with the OP expected results - you should hear sound and it should vibrate.

Thanks for pinging the UX team!
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(mpotharaju)
Thanks Tiffanie. 

Changing to 2.5 blocker and assign P2 priority
blocking-b2g: 2.5? → 2.5+
Flags: needinfo?(mpotharaju)
Priority: -- → P2
From comment0 & comment10, we can know this bug is Aries-exclusive bug and the bug situation is that the ringtone can only be heard from the BT headset, instead of both speaker and headset.

This issue should be SONY's bug. The FxOS doesn't control the audio output, we set the available output devices to AudioPolicyManager (In Android's HAL), then AudioPolicyManager would decide the final output device.
unblock this issue per comment 15 and comment 18. Need further follow up if get Sony's support.
Blocks: spark-device
blocking-b2g: 2.5+ → ---
Flags: needinfo?(mpotharaju)
Flags: needinfo?(wmathanaraj)
Doesn't block 2.5, based on Triage.
Flags: needinfo?(mpotharaju)
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.