[APZ] Gmail sidemenu rendered with grayscale AA instead of Sub-pixel AA when enable e10s and APZ.

RESOLVED DUPLICATE of bug 1122916

Status

()

RESOLVED DUPLICATE of bug 1122916
3 years ago
3 years ago

People

(Reporter: alice0775, Unassigned)

Tracking

({regression, reproducible})

42 Branch
Unspecified
Windows 7
regression, reproducible
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
This problem only happen when e10s and APZ enabled both (Nightly42.0a1 default now).

This problem only happen when browser is normal sizemode.
The problem is gone when browser maximized.

Steps To Reproduce:
1. Start Firefox with normal window sizemode
2. Open Gmail and Sign In


Actual Results:
Gmail sidemenu rendered with grayscale AA instead of sub-pixel AA.



Expected results:
Gmail sidemenu should render with sub-pixel AA.


Regression window(with forcibly enabled e10s and APZ):
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=24fe1880f83b&tochange=d3b41b0ead7d

Regressed by: d3b41b0ead7d	David Anderson — Remove apz.subframe.enabled and assume it is always true. (bug 1128761, r=kats)
Flags: needinfo?(dvander)
(Reporter)

Comment 1

3 years ago
The problem is gone when bookmark toolbar is hidden.



Steps To Reproduce:
1. Start Firefox with normal window sizemode
2. Show bookmarks toolbar
3. Open Gmail and Sign-In

Actual Results:
Gmail sidemenu rendered with grayscale AA instead of sub-pixel AA.

Expected results:
Gmail sidemenu should render with sub-pixel AA.
(Reporter)

Comment 2

3 years ago
Created attachment 8644925 [details]
screenshot
(Reporter)

Updated

3 years ago
See Also: → bug 1190901
(Reporter)

Updated

3 years ago
OS: Unspecified → Windows 7
(Reporter)

Comment 3

3 years ago
Application Basics
------------------

Name: Firefox
Version: 42.0a1
Build ID: 20150806103223
Update Channel: nightly
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Multiprocess Windows: 1/1 (default: true)
Safe Mode: false


Graphics
--------

Adapter Description: AMD Radeon HD 6450
Adapter Drivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM: 1024
Asynchronous Pan/Zoom: wheel input enabled
ClearType Parameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 300
Device ID: 0x6779
Direct2D Enabled: true
DirectWrite Enabled: true (6.2.9200.17292)
Driver Date: 6-22-2015
Driver Version: 15.200.1046.0
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC)
Subsys ID: 23111787
Supports Hardware H264 Decoding: true
Vendor ID: 0x1002
WebGL Renderer: Google Inc. -- ANGLE (AMD Radeon HD 6450 Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0
I think this is a dupe of bug 1122916. Please reopen if you disagree.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1122916
(Reporter)

Updated

3 years ago
tracking-e10s: ? → ---
tracking-firefox42: ? → ---
No longer blocks: 1128761
status-firefox41: unaffected → ---
status-firefox42: affected → ---
Flags: needinfo?(dvander)
You need to log in before you can comment on or make changes to this bug.