Closed Bug 1192255 Opened 6 years ago Closed 5 years ago

NUWA assertion with Msg_LastPrivateDocShellDestroyed

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(firefox43 fixed)

RESOLVED FIXED
FxOS-S6 (04Sep)
Tracking Status
firefox43 --- fixed

People

(Reporter: gwagner, Assigned: cyu)

References

Details

Attachments

(2 files, 1 obsolete file)

Attached file gdb bt
Seen during monkey testing on aries with debug gecko.
Flags: needinfo?(cyu)
We shouldn't send last-pb-context-exited to Nuwa since there won't be browsing activities in it.
Assignee: nobody → cyu
Flags: needinfo?(cyu)
On a closer look, ContentParent::Observe() is really a mess w.r.t. Nuwa process. There needs to be compile-time and runtime checks, which is error-prone.

Given that only few notifications are safe to the ready Nuwa process, we need a cleaner way to do it in ContentParent. The current idea is unregistering the Nuwa process of those notifications once ready, only leaving the notifications that are necessary.
Duplicate of this bug: 1186707
Update to the previous patch: fix the build failures on non-Nuwa platforms for handling "nsPref:Changed".
Attachment #8647956 - Attachment is obsolete: true
Attachment #8647956 - Flags: review?(khuey)
Attachment #8648001 - Flags: review?(khuey)
Comment on attachment 8648001 [details] [diff] [review]
Clean up ContentParent's observer topics for the Nuwa process.

Cancel the request since this revision has regressions. Retest on try and will update the patch once the results are green.
Attachment #8648001 - Flags: review?(khuey)
Comment on attachment 8648001 [details] [diff] [review]
Clean up ContentParent's observer topics for the Nuwa process.

Windows 8 browser chrome tests looks good. Request review for the patch.
Attachment #8648001 - Flags: review?(khuey)
Comment on attachment 8648001 [details] [diff] [review]
Clean up ContentParent's observer topics for the Nuwa process.

Review of attachment 8648001 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/ipc/ContentParent.cpp
@@ +3018,5 @@
>          return NS_OK;
>  
> +    // The Nuwa process unregisters the topics after it becomes ready except for
> +    // the ones listed in sNuwaSafeObserverTopics. If the topic needs to be
> +    // observed by the Nuwa process, either for:

s/ for//

@@ +3024,5 @@
> +    // 1.1 The state can safely happen (only run on the main thread) in the Nuwa
> +    //     process (e.g. "a11y-init-or-shutdown"), or
> +    // 1.2 The topic doesn't send an IPC message (e.g. "xpcom-shutdown").
> +    // 2. The topic needs special handling (e.g. nsPref:Changed),
> +    // add the topic to sNuawSafeObserverTopics and then handle it if necessary.

sNuwa...
Attachment #8648001 - Flags: review?(khuey) → review+
url:        https://hg.mozilla.org/integration/b2g-inbound/rev/c46f4154cceac710d34729778b2528f1422962e0
changeset:  c46f4154cceac710d34729778b2528f1422962e0
user:       Cervantes Yu <cyu@mozilla.com>
date:       Fri Aug 14 15:41:54 2015 +0800
description:
Bug 1192255: Clean up ContentParent's observer topics for the Nuwa process. r=khuey
https://hg.mozilla.org/mozilla-central/rev/c46f4154ccea
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S6 (04Sep)
You need to log in before you can comment on or make changes to this bug.