Closed Bug 1192312 Opened 4 years ago Closed 4 years ago

Use MediaCodecSource for camera recording since gonk L

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(feature-b2g:2.2r+, firefox43 fixed, b2g-v2.2r fixed, b2g-master fixed)

RESOLVED FIXED
FxOS-S5 (21Aug)
feature-b2g 2.2r+
Tracking Status
firefox43 --- fixed
b2g-v2.2r --- fixed
b2g-master --- fixed

People

(Reporter: sotaro, Assigned: sotaro)

References

Details

Attachments

(1 file, 1 obsolete file)

+++ This bug was initially created as a clone of Bug #1187364 +++

Since android L, MediaCodecSource is used instead of OMXCodec. MediaCodec expose more capability than OMXCodec, it seems better to use MediaCodecSource if possible.
Assignee: nobody → sotaro.ikeda.g
I confirmed that attachment 8645034 [details] [diff] [review] works on master nexus-5-l.
Attachment #8645034 - Flags: review?(aosmond)
Comment on attachment 8645034 [details] [diff] [review]
patch - Use MediaCodecSource for camera recording since gonk L

Review of attachment 8645034 [details] [diff] [review]:
-----------------------------------------------------------------

r+ with some minor nits.

::: dom/camera/GonkRecorder.cpp
@@ +1367,5 @@
> +        // release the camera source due to the camera's lock
> +        // and unlock mechanism.
> +        if (cameraSource != NULL) {
> +            cameraSource->stop();
> +        }

Is this check necessary? It shouldn't be null, and if it is, we should fail in setupMPEG4Recording and setupMPEG2TSRecording before calling setupVideoEncoder.
Attachment #8645034 - Flags: review?(aosmond) → review+
(In reply to Andrew Osmond [:aosmond] from comment #5)
> 
> Is this check necessary? It shouldn't be null, and if it is, we should fail
> in setupMPEG4Recording and setupMPEG2TSRecording before calling
> setupVideoEncoder.

On b2g, the check is not necessary. I am going to remove it. It exists on android to support video source surface.
Apply the comment. Carry "r=aosmond".
Attachment #8645034 - Attachment is obsolete: true
Attachment #8648051 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/db0d6f44e3e9
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S5 (21Aug)
feature-b2g: --- → 2.2r+
You need to log in before you can comment on or make changes to this bug.