The parser for multiple emails in one field is broken.

RESOLVED DUPLICATE of bug 1059988

Status

--
minor
RESOLVED DUPLICATE of bug 1059988
3 years ago
3 years ago

People

(Reporter: dsage84, Unassigned)

Tracking

38 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150630154324

Steps to reproduce:

Enter two email addresses in one TO: field when creating an email. It can be separated by either a comma or semi colon. 


Actual results:

"name@email.com; name2"@email.com


Expected results:

name@email.com; name2@email.com
(Reporter)

Updated

3 years ago
Severity: normal → minor
Component: Untriaged → Message Compose Window
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
(Reporter)

Comment 1

3 years ago
I should add this doesn't happen until after you hit send. It isn't visible to the user until they check the bounced email when it fails to send.

Comment 2

3 years ago
> It can be separated by ... [a] semi colon. 

That's not allowed. Semi-colons in email address lists are used to terminate groups, not to separate addresses. See section 3.4 of RFC 5322: <http://www.faqs.org/rfcs/rfc5322.html>.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1059988
You need to log in before you can comment on or make changes to this bug.