If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Scroll wheel scrolling is jerky

RESOLVED WORKSFORME

Status

()

Core
Panning and Zooming
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: Ray Satiro, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150807030210

Steps to reproduce:

I'm using the scroll wheel to scroll down webpages but it is jerky. However I can move the scroll bar smoothly if I click the mouse pointer on it and drag it or if I middle-click in the page to turn on scrolling and then move the mouse down. It's not reproducible outside of this session. I'm not running any plugins or extensions. In this session I have the issue in any window e10s or not.


Actual results:

The scrollbar is jerky. This is unlike bug #1109364 where I reported mouse scroll lags and bug #1133928 where I reported e10s momentary freezes because none of the symptoms as described in those bugs are happening here.

I'm attaching two videos showing the difference in scrolling. One is from the current session where I have several tabs open. The second is from a clean profile where only one tab is open. It's very hard to tell even though I turned up the framerate but what's happening in the 'bad scroll' video is every time I turn the mousewheel to scroll it looks like it will start but hesitates for a fraction of a second before continuing. That results in a jerky scroll.

I have smooth scroll enabled in both profiles. When I disable smooth scrolling in the problem session there doesn't appear to be that delay but then scrolling isn't smooth.


Expected results:

The scroll wheel should be smooth. Before this build I used 2015-07-20 for two weeks without any problem. Unfortunately because this issue doesn't appear to be reproducible in a clean profile I cannot establish a regression window.
(Reporter)

Comment 1

2 years ago
Created attachment 8645300 [details]
bad scroll
(Reporter)

Comment 2

2 years ago
Created attachment 8645301 [details]
good scroll
This might be bug 1160540. Can you try running the build at http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/mstange@themasta.com-16c110ea9dce/try-win32/firefox-42.0a1.en-US.win32.zip for several hours and see whether that fixes it?

Updated

2 years ago
Component: Untriaged → Panning and Zooming
Flags: needinfo?(raysatiro)
Product: Firefox → Core

Updated

2 years ago
Version: 42 Branch → Trunk
(Reporter)

Comment 4

2 years ago
(In reply to Markus Stange [:mstange] from comment #3)
> This might be bug 1160540. Can you try running the build at
> http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/mstange@themasta.
> com-16c110ea9dce/try-win32/firefox-42.0a1.en-US.win32.zip for several hours
> and see whether that fixes it?

I've been running the build since last night and it seems to be ok so far. But since I've only seen the issue once and I don't have a way to reproduce so I can't say whether or not the build is helping. I'll try to keep it running until Tuesday at which point I'll have to apply windows updates and reboot, but I'll start it again after that and let you know at the end of this week what's happened. If you'll need an earlier update let me know.
Thanks! It might be a better idea then if you ran a regular nightly for a while and see whether the issue comes back.
(Reporter)

Comment 6

2 years ago
Ok good point. I'll run your build until Tuesday and then switch back to 20150807030210 for at most the rest of the week and let you know.
(Reporter)

Comment 7

2 years ago
All my tabs just crashed. I'm still using 16c110ea9dce. I chose to file a report and reload the tabs. I don't know where the report was filed or what was filed. Are you able to access that information? How would I access that information?
I'm not sure if it works for builds from the tryserver, but usually you can get at the crash report by going to about:crashes. You can paste the crash IDs here if you want to.
(Reporter)

Comment 9

2 years ago
Thanks, I forgot about that.

EXCEPTION_ACCESS_VIOLATION_READ
https://crash-stats.mozilla.com/report/index/70f8705d-a5b8-4ef6-a83d-867c02150811
Thanks. The crash was inside the GC (don't ask me how I figured that out) so it was probably bug 1191465, which has been crashing nightly builds left and right over the weekend. It's fixed in Nightly, just not in the tryserver build I asked you to run. (Sorry.)
(Reporter)

Comment 11

2 years ago
Thanks for that information. I'm on 20150811030206 43.0a1 now and the jerky scroll is back, so I suspect your patch did something.
Flags: needinfo?(raysatiro)
(Reporter)

Comment 12

2 years ago
Ive been running ec77f5c19262 20150811011940 since Wednesday 8/12 and it's been fine so far. I got the link from bug #1160540 comment 44.
(Reporter)

Comment 13

2 years ago
I ran your ec77f5c19262 20150811011940 from 8/12 - 8/22 without issue. This evening I changed to Nightly 20150823030214 43.0a1 and after a few hours the jerky scroll is back again. Is there any chance one of your fixes will make it in? Also, do you know the root cause of this issue? I think it's pretty strange.
I think all the fixes we had in the pipe have landed now - are you still seeing this issue in Nightly or Developer Edition?
Blocks: 1013364
Flags: needinfo?(raysatiro)
(Reporter)

Comment 15

2 years ago
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #14)
> I think all the fixes we had in the pipe have landed now - are you still
> seeing this issue in Nightly or Developer Edition?

I've been using ESR for the last few months, and I can't say whether or not there may still be an issue.
Flags: needinfo?(raysatiro)
OK, thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.