mozregression GUI date range is hard to use and also european style for US

RESOLVED FIXED

Status

Testing
mozregression
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Ray Satiro, Assigned: MikeLing)

Tracking

42 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

49 bytes, text/x-github-pull-request
parkouss
: review+
Details | Review | Splinter Review
(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150807030210

Steps to reproduce:

I'm using GUI 0.3 which includes mozregression 0.37 in Windows 7 x64. In the GUI I am asked to pick a date range. 


Actual results:

When I chose a date the first time all sorts of weird things happened to the year. It was like 1752 or something and it wouldn't let me change it. Then I could change it but I couldn't change the other segments and anything I typed moved the cursor to the next segment of the date. It was pretty buggy.

I restarted and that went away but I still couldn't set the date right, but that time it was because the date format is Euro style which I didn't expect since I'm in the United States. So I tried to set the day in the month section and it just wouldn't set.


Expected results:

I think that date control is buggy and hard to use. I think you should consider just using a text box and let users type the ISO style YYYY-MM-DD and parse that. It would be the same as the command line and I'd guess what most users expect.
(In reply to Ray Satiro from comment #0)
> Actual results:
> 
> When I chose a date the first time all sorts of weird things happened to the
> year. It was like 1752 or something and it wouldn't let me change it. Then I
> could change it but I couldn't change the other segments and anything I
> typed moved the cursor to the next segment of the date. It was pretty buggy.

This is strange, because we just use the QDateTimeEdit widget from the Qt framework
(http://doc.qt.io/qt-4.8/qdatetimeedit.html) and I never saw this error using
mozregression-GUI. Can you reproduce it ?

> I restarted and that went away but I still couldn't set the date right, but
> that time it was because the date format is Euro style which I didn't expect
> since I'm in the United States. So I tried to set the day in the month
> section and it just wouldn't set.

This is definitely a bug!

> Expected results:
> 
> I think that date control is buggy and hard to use. I think you should
> consider just using a text box and let users type the ISO style YYYY-MM-DD
> and parse that. It would be the same as the command line and I'd guess what
> most users expect.

Well, I think using the QDateTimeEdit edit is the right thing to do. It exists
exactly for this kind of things, and allow us to avoid checks - making our life
easier. Unless it is really buggy or unusable, I don't think we should use plain
text edit instead. But we should change the format, and check that it is usable. :)

Still that's my own opinion, and I'm not strongly opposed to remove that special
widget. Asking :wlach to have another opinion here.
Flags: needinfo?(wlachance)
I agree with Julien that a specialized widget is the right approach here. We may need to tweak it to get the optimal behaviour. No real opinions there myself as I'm not a Qt expert. :)
Flags: needinfo?(wlachance)
(Assignee)

Comment 3

2 years ago
Created attachment 8646380 [details] [review]
PR for bug 1192487

After talk with :parkouss on IRC, we decide just to change the data format from dd/mm/yyyy to yyyy-mm-dd, for now. Hope it will sufficient.
Attachment #8646380 - Flags: review?(j.parkouss)
(Assignee)

Updated

2 years ago
Assignee: nobody → sabergeass
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Comment on attachment 8646380 [details] [review]
PR for bug 1192487

Thanks MikeLing!

Just landed: https://github.com/mozilla/mozregression/commit/20d533f1f18c59eea8e4594f6cd62adb163c6265
Attachment #8646380 - Flags: review?(j.parkouss) → review+
Ok, I'm closing this as resolved. In the next release that will contain that patch, if you still have issues Ray then please reopen the bug or fill another one. Thanks for reporting this!
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.