javascript strict warnings in mailWindowOverlay.js

VERIFIED DUPLICATE of bug 68525

Status

SeaMonkey
MailNews: Message Display
--
trivial
VERIFIED DUPLICATE of bug 68525
16 years ago
13 years ago

People

(Reporter: K Chayka, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
Future
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
win32 build 2002011003, win98se

The following displays twice in the js console when mail is first started:

Error: Components.classes['@mozilla.org;timeline-service;1'] has no properties
Source File: chrome://messenger/content/mailWindowOverlay.js
Line: 34

This has been in the last several builds, I think.

Updated

16 years ago
QA Contact: esther → stephend
Confirming, I've seen this too, but I *think* it's harmless. DP would know...
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
Timeline is enabled only in DEBUG builds of windows by default. On the rest it
is enabled with MOZ_TIMELINE or --enable-timeline is set...

C++ code that doesn't have timeline just noops out. But for js there is no such
facility. Look like mailwindowOverlay.js is using timeline and is checked in.

It is harmless but I wouldnt expect this code to be run in non-debug builds.
*** Bug 119386 has been marked as a duplicate of this bug. ***

Comment 4

16 years ago
There are both javascript warnings and errors. Messing up the console.
I'm using a nightly build so the timeline shouldn't be there right?

Warning: reference to undefined property
Components.classes['@mozilla.org;timeline-service;1']
Source File: chrome://messenger/content/mailWindowOverlay.js
Line: 34

Error: Components.classes['@mozilla.org;timeline-service;1'] has no properties
Source File: chrome://messenger/content/mailWindowOverlay.js
Line: 34

Comment 5

16 years ago
This bug is preventing me from running my JavaScript S/MIME automated test. It 
failed to launch the Messenger window when running the following JavaScript 
code:

setTimeout(lastWindow.OpenMessenger,1);
setTimeout(closeAlert,4000);
alert('Loading Messenger window... Will close automatically.');

The last workable build for me is 2001121103.

Fixing this bug is critical for me to continue the S/MIME automation effort. 
Thanks.
Severity: normal → major
Varada should own this, but he's currently on sabbatical.

Updated

16 years ago
Severity: major → blocker

Comment 7

16 years ago
Created attachment 65461 [details] [diff] [review]
Draft patch...

Something like this should get this through. I haven't tested it or anything.

Comment 8

16 years ago
Any update on this bug?

Comment 9

16 years ago
Looks like DP has a patch.  Who can review this?
Keywords: nsbeta1

Comment 10

16 years ago
Sean, could you review this and then pass it on for the super review?
Status: NEW → ASSIGNED

Comment 11

16 years ago
Any new news?  Thanks!

Comment 12

16 years ago
Tried with today's trunk build (2002020110), and this problem seems is gone.  I 
am able to run my JavaScript S/MIME automated test now.

Comment 13

16 years ago
*** Bug 124137 has been marked as a duplicate of this bug. ***

Comment 14

16 years ago
marking WFM based on comments.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Keywords: nsbeta1 → nsbeta1-
Resolution: --- → WORKSFORME
Well... I still see

Warning: reference to undefined property
Components.classes['@mozilla.org;timeline-service;1']
Source File: chrome://messenger/content/mailWindowOverlay.js
Line: 39

Perhaps we should reopen this and scope it towards the only warning I currently see?

Comment 16

16 years ago
sure. I'll reopen since we still get the js error. Since it doesn't appear to be
a blocker, I'm changing the severity and moving out.
Severity: blocker → trivial
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Target Milestone: --- → Future
updating summary to reflect changes.
Summary: js error at mail startup: Components.classes['@mozilla.org;timeline-service;1'] has no properties → JS strict warning in mailWindowOverlay.js

Comment 18

16 years ago

*** This bug has been marked as a duplicate of 68525 ***
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
Summary: JS strict warning in mailWindowOverlay.js → javascript strict warnings in mailWindowOverlay.js
verified dup.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.