can't set proxy for plugin-container.exe

RESOLVED DUPLICATE of bug 562880

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 562880
2 years ago
2 years ago

People

(Reporter: 554687412, Unassigned)

Tracking

40 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8645407 [details]
无标题.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150730171029

Steps to reproduce:

I have set socks proxy ( 127.0.0.1:1080) in firefox setting.


Actual results:

I inspect the network using proxifier and find that plugin-container.exe and firefox.exe have different targets. Firefox.exe uses the proxy perfectly while plugin-container.exe bypass the proxy. 


Expected results:

firefox.exe and plugin-container.exe have the same target (127.0.0.1:1080).

Comment 1

2 years ago
What is this 'plugin-container.exe'? You seem to use Beta, so you don't have e10s enabled, right? Do you have a plugin running? Which one? Does it actually make network calls bypassing the proxy?
Flags: needinfo?(554687412)
(Reporter)

Comment 2

2 years ago
(In reply to Nickolay_Ponomarev from comment #1)
> What is this 'plugin-container.exe'? You seem to use Beta, so you don't have
> e10s enabled, right? Do you have a plugin running? Which one? Does it
> actually make network calls bypassing the proxy?

Yes, I am using lastest beta version firefox(x64) on windows10. I don't enable e10s. Adobe Flash is running when i inspect the traffic. I think this plugin-container.exe actually makes network calls bypassing the proxy. The following is part of proxifier's log file(the first row is time,the second row is application's name,the third row is its target, the last row is proxifier's rule which doesn't matter.). You can see that firefox.exe's target is always the proxy(127.0.0.1:1080),while the plugin-container.exe's target never equals the proxy. I log this when i am watching live stream on this website(http://www.douyutv.com/directory/game/LOL). you can try it yourself.:

[2015.08.10 00:27:17] firefox.exe (4292) *64 - 127.0.0.1:1080 matching Localhost rule : direct connection
[2015.08.10 00:27:17] firefox.exe (4292) *64 - 127.0.0.1:1080 open directly
[2015.08.10 00:27:17] Shadowsocks.exe (5688) - [2604:180:3:42b::d26c]:9797 (IPv6) matching ipv6
[2015.08.10 00:27:17] Shadowsocks.exe (5688) - [2604:180:3:42b::d26c]:9797 (IPv6) open directly
[2015.08.10 00:27:18] firefox.exe (4292) *64 - 127.0.0.1:1080 close, 537 bytes sent, 15793130 bytes (15.0 MB) received, lifetime 02:12
[2015.08.10 00:27:18] Shadowsocks.exe (5688) - [2604:180:3:42b::d26c]:9797 (IPv6) close, 539 bytes sent, 15793126 bytes (15.0 MB) received, lifetime 02:12
[2015.08.10 00:27:18] plugin-container.exe (8428) *64 - danmu.douyutv.com:12601 close, 214 bytes sent, 45976 bytes (44.8 KB) received, lifetime 02:11
[2015.08.10 00:27:18] plugin-container.exe (8428) *64 - 119.90.49.101:8003 close, 675 bytes sent, 1342 bytes (1.31 KB) received, lifetime 02:13
[2015.08.10 00:27:18] firefox.exe (4292) *64 - 127.0.0.1:1080 matching Localhost rule : direct connection
[2015.08.10 00:27:18] firefox.exe (4292) *64 - 127.0.0.1:1080 open directly
[2015.08.10 00:27:18] firefox.exe (4292) *64 - 127.0.0.1:1080 matching Localhost rule : direct connection
[2015.08.10 00:27:18] firefox.exe (4292) *64 - 127.0.0.1:1080 open directly
[2015.08.10 00:27:18] firefox.exe (4292) *64 - 127.0.0.1:1080 matching Localhost rule : direct connection
[2015.08.10 00:27:18] firefox.exe (4292) *64 - 127.0.0.1:1080 open directly
[2015.08.10 00:27:18] firefox.exe (4292) *64 - 127.0.0.1:1080 matching Localhost rule : direct connection
[2015.08.10 00:27:18] firefox.exe (4292) *64 - 127.0.0.1:1080 open directly
[2015.08.10 00:27:18] firefox.exe (4292) *64 - 127.0.0.1:1080 matching Localhost rule : direct connection
[2015.08.10 00:27:18] firefox.exe (4292) *64 - 127.0.0.1:1080 open directly
[2015.08.10 00:27:18] firefox.exe (4292) *64 - 127.0.0.1:1080 matching Localhost rule : direct connection
[2015.08.10 00:27:18] firefox.exe (4292) *64 - 127.0.0.1:1080 open directly
[2015.08.10 00:27:18] Shadowsocks.exe (5688) - [2604:180:3:42b::d26c]:9797 (IPv6) matching ipv6
[2015.08.10 00:27:18] Shadowsocks.exe (5688) - [2604:180:3:42b::d26c]:9797 (IPv6) matching ipv6
[2015.08.10 00:27:18] Shadowsocks.exe (5688) - [2604:180:3:42b::d26c]:9797 (IPv6) matching ipv6
[2015.08.10 00:27:18] firefox.exe (4292) *64 - 127.0.0.1:1080 matching Localhost rule : direct connection
[2015.08.10 00:27:18] firefox.exe (4292) *64 - 127.0.0.1:1080 open directly
[2015.08.10 00:27:18] Shadowsocks.exe (5688) - [2604:180:3:42b::d26c]:9797 (IPv6) matching ipv6
[2015.08.10 00:27:18] Shadowsocks.exe (5688) - [2604:180:3:42b::d26c]:9797 (IPv6) open directly
[2015.08.10 00:27:18] Shadowsocks.exe (5688) - [2604:180:3:42b::d26c]:9797 (IPv6) open directly
[2015.08.10 00:27:18] Shadowsocks.exe (5688) - [2604:180:3:42b::d26c]:9797 (IPv6) open directly
[2015.08.10 00:27:18] Shadowsocks.exe (5688) - [2604:180:3:42b::d26c]:9797 (IPv6) open directly
[2015.08.10 00:27:21] firefox.exe (4292) *64 - 127.0.0.1:1080 matching Localhost rule : direct connection
[2015.08.10 00:27:21] firefox.exe (4292) *64 - 127.0.0.1:1080 open directly
[2015.08.10 00:27:21] firefox.exe (4292) *64 - 127.0.0.1:1080 matching Localhost rule : direct connection
[2015.08.10 00:27:21] firefox.exe (4292) *64 - 127.0.0.1:1080 open directly
[2015.08.10 00:27:21] Shadowsocks.exe (5688) - [2604:180:3:42b::d26c]:9797 (IPv6) matching ipv6
[2015.08.10 00:27:21] Shadowsocks.exe (5688) - [2604:180:3:42b::d26c]:9797 (IPv6) matching ipv6
[2015.08.10 00:27:22] Shadowsocks.exe (5688) - [2604:180:3:42b::d26c]:9797 (IPv6) open directly
[2015.08.10 00:27:22] Shadowsocks.exe (5688) - [2604:180:3:42b::d26c]:9797 (IPv6) open directly
[2015.08.10 00:27:22] plugin-container.exe (8428) *64 - resolve secgate.douyutv.com : proxy
[2015.08.10 00:27:22] plugin-container.exe (8428) *64 - secgate.douyutv.com:843 matching Default rule :  using proxy 127.0.0.1:1080 SOCKS5
[2015.08.10 00:27:22] plugin-container.exe (8428) *64 - secgate.douyutv.com:843 open through proxy 127.0.0.1:1080 SOCKS5
[2015.08.10 00:27:22] Shadowsocks.exe (5688) - [2604:180:3:42b::d26c]:9797 (IPv6) matching ipv6[2015.08.10 00:27:22] plugin-container.exe (8428) *64 - secgate.douyutv.com:843 GetSockName : 127.0.0.1:5644
[2015.08.10 00:27:22] Shadowsocks.exe (5688) - [2604:180:3:42b::d26c]:9797 (IPv6) open directly
[2015.08.10 00:27:22] plugin-container.exe (8428) *64 - 119.90.49.108:843 matching Default rule :  using proxy 127.0.0.1:1080 SOCKS5
[2015.08.10 00:27:23] plugin-container.exe (8428) *64 - 119.90.49.108:843 open through proxy 127.0.0.1:1080 SOCKS5
[2015.08.10 00:27:23] Shadowsocks.exe (5688) - [2604:180:3:42b::d26c]:9797 (IPv6) matching ipv6[2015.08.10 00:27:23] Shadowsocks.exe (5688) - [2604:180:3:42b::d26c]:9797 (IPv6) open directly
[2015.08.10 00:27:23] plugin-container.exe (8428) *64 - 119.90.49.108:843 close, 23 bytes sent, 274 bytes received, lifetime <1 sec
[2015.08.10 00:27:23] Shadowsocks.exe (5688) - [2604:180:3:42b::d26c]:9797 (IPv6) close, 38 bytes sent, 282 bytes received, lifetime <1 sec
[2015.08.10 00:27:23] plugin-container.exe (8428) *64 - 119.90.49.108:8039 matching Default rule :  using proxy 127.0.0.1:1080 SOCKS5
[2015.08.10 00:27:23] plugin-container.exe (8428) *64 - 119.90.49.108:8039 open through proxy 127.0.0.1:1080 SOCKS5
[2015.08.10 00:27:23] plugin-container.exe (8428) *64 - 119.90.49.108:8039 GetSockName : 127.0.0.1:5657
[2015.08.10 00:27:23] firefox.exe (4292) *64 - 127.0.0.1:1080 matching Localhost rule : direct connection
[2015.08.10 00:27:23] firefox.exe (4292) *64 - 127.0.0.1:1080 open directly
[2015.08.10 00:27:23] Shadowsocks.exe (5688) - [2604:180:3:42b::d26c]:9797 (IPv6) matching ipv6[2015.08.10 00:27:24] Shadowsocks.exe (5688) - [2604:180:3:42b::d26c]:9797 (IPv6) open directly
[2015.08.10 00:27:24] Shadowsocks.exe (5688) - [2604:180:3:42b::d26c]:9797 (IPv6) close, 610 bytes sent, 226 bytes received, lifetime <1 sec
[2015.08.10 00:27:24] firefox.exe (4292) *64 - 127.0.0.1:1080 close, 608 bytes sent, 230 bytes received, lifetime 00:01
[2015.08.10 00:27:24] firefox.exe (4292) *64 - 127.0.0.1:1080 matching Localhost rule : direct connection
[2015.08.10 00:27:24] firefox.exe (4292) *64 - 127.0.0.1:1080 open directly
[2015.08.10 00:27:24] Shadowsocks.exe (5688) - [2604:180:3:42b::d26c]:9797 (IPv6) matching ipv6[2015.08.10 00:27:24] Shadowsocks.exe (5688) - [2604:180:3:42b::d26c]:9797 (IPv6) open directly
[2015.08.10 00:27:24] plugin-container.exe (8428) *64 - resolve danmu.douyutv.com : proxy
[2015.08.10 00:27:24] plugin-container.exe (8428) *64 - danmu.douyutv.com:843 matching Default rule :  using proxy 127.0.0.1:1080 SOCKS5
[2015.08.10 00:27:25] plugin-container.exe (8428) *64 - danmu.douyutv.com:843 open through proxy 127.0.0.1:1080 SOCKS5
[2015.08.10 00:27:25] Shadowsocks.exe (5688) - [2604:180:3:42b::d26c]:9797 (IPv6) matching ipv6[2015.08.10 00:27:25] Shadowsocks.exe (5688) - [2604:180:3:42b::d26c]:9797 (IPv6) open directly
[2015.08.10 00:27:25] plugin-container.exe (8428) *64 - danmu.douyutv.com:12602 matching Default rule :  using proxy 127.0.0.1:1080 SOCKS5
[2015.08.10 00:27:25] plugin-container.exe (8428) *64 - danmu.douyutv.com:12602 open through proxy 127.0.0.1:1080 SOCKS5
[2015.08.10 00:27:25] plugin-container.exe (8428) *64 - danmu.douyutv.com:12602 GetSockName : 127.0.0.1:5679
[2015.08.10 00:27:25] Shadowsocks.exe (5688) - [2604:180:3:42b::d26c]:9797 (IPv6) close, 52 bytes sent, 622 bytes received, lifetime <1 sec
[2015.08.10 00:27:25] plugin-container.exe (8428) *64 - danmu.douyutv.com:843 close, 23 bytes sent, 614 bytes received, lifetime 00:01
[2015.08.10 00:27:25] plugin-container.exe (8428) *64 - secgate.douyutv.com:843 close, 23 bytes sent, 0 bytes received, lifetime 00:03
[2015.08.10 00:27:25] Shadowsocks.exe (5688) - [2604:180:3:42b::d26c]:9797 (IPv6) close, 54 bytes sent, 0 bytes received, lifetime 00:03
[2015.08.10 00:27:25] plugin-container.exe (8428) *64 - secgate.douyutv.com:8105 matching Default rule :  using proxy 127.0.0.1:1080 SOCKS5
[2015.08.10 00:27:25] plugin-container.exe (8428) *64 - secgate.douyutv.com:8105 open through proxy 127.0.0.1:1080 SOCKS5
[2015.08.10 00:27:25] plugin-container.exe (8428) *64 - secgate.douyutv.com:8105 GetSockName : 127.0.0.1:5683
Flags: needinfo?(554687412)

Comment 3

2 years ago
I'm not sure how to read the proxifier log, but if it's Flash making these connections, it looks like a duplicate of bug 562880 (i.e. not a Firefox bug). You know that flash runs inside the plugin-container.exe, right?
Component: Untriaged → Plug-ins
Product: Firefox → Core
(Reporter)

Comment 4

2 years ago
I read that bug and i think these two bugs are the same. I am sorry that i didn't find that bug and have opened a new report. Maybe it is the adobe flash's bug.

Comment 5

2 years ago
No problem! Thanks for confirming my suspicion.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 562880
You need to log in before you can comment on or make changes to this bug.