Last Comment Bug 1192600 - create deterministic header list ical.h
: create deterministic header list ical.h
Status: RESOLVED FIXED
:
Product: Calendar
Classification: Client Software
Component: Internal Components (show other bugs)
: Lightning 4.0.0.1
: All Linux
-- normal (vote)
: 4.5
Assigned To: Carsten Schoenert
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-09 01:19 PDT by Carsten Schoenert
Modified: 2015-09-04 13:10 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Generate-sorted-ical-header-list.patch (1.40 KB, patch)
2015-08-09 01:19 PDT, Carsten Schoenert
philipp: review+
Details | Diff | Splinter Review
bug1192600-updatedHeaders.diff (1.67 KB, patch)
2015-08-22 02:48 PDT, [:MakeMyDay]
makemyday: review+
Details | Diff | Splinter Review

Description User image Carsten Schoenert 2015-08-09 01:19:53 PDT
Created attachment 8645420 [details] [diff] [review]
Generate-sorted-ical-header-list.patch

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0 Iceweasel/38.1.0
Build ID: 20150711212448

Steps to reproduce:

The Debian Reproducible Team (https://reproducible.debian.net/reproducible.html) catched a issue while building the Debian Icedove (Thunderbird) twice. The analyses shows up that the header ical.h could not be generated reproducible and the whole reproducible build of Icedove is failing on that.

Further information can be found on https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=794456




Actual results:

The created ical.h is changing with every build as the list of the headers is created randomly.




Expected results:

To create a deterministic list inside ical.h only few changes are needed. The current upstream version of libical add the needed changes long ago. If bug 1160990 is resolved no further action is needed. Otherwise look at the appended patch.
Comment 1 User image [:MakeMyDay] 2015-08-09 13:17:49 PDT
Comment on attachment 8645420 [details] [diff] [review]
Generate-sorted-ical-header-list.patch

Setting r? for this, as updating libical in near future is probably unlikely.
Comment 2 User image Philipp Kewisch [:Fallen] 2015-08-10 16:57:16 PDT
Comment on attachment 8645420 [details] [diff] [review]
Generate-sorted-ical-header-list.patch

Review of attachment 8645420 [details] [diff] [review]:
-----------------------------------------------------------------

Fine with me, r=philipp I'd appreciate if we could give this a try run. Carsten, do you have hg access to take care? If not, please needinfo me or MakeMyDay.
Comment 3 User image Carsten Schoenert 2015-08-11 00:06:52 PDT
Hello Philipp,

thanks for take care, I haven't access to hg and I'd like to not necessary handle this if possible. I'm not really firm with workflow you guys doing.
Comment 4 User image Philipp Kewisch [:Fallen] 2015-08-11 00:43:30 PDT
Sure no problem. Here is the try push: https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=cd6ab982f453
Note that tests will fail since they are failing on c-c, it is only important to see if there are new calendar test failures.
Comment 5 User image [:MakeMyDay] 2015-08-22 02:48:37 PDT
Created attachment 8651372 [details] [diff] [review]
bug1192600-updatedHeaders.diff

Patch with updated headers for checkin.
Comment 6 User image [:MakeMyDay] 2015-08-22 02:51:20 PDT
Carsten, I hope you don't mind I have updated the patch headers for you. As the try log looked good, let's get this in.
Comment 7 User image Carsten Schoenert 2015-08-22 03:13:11 PDT
Go ahead! :-)
Thank for going further!
Comment 8 User image aleth [:aleth] 2015-09-04 13:08:58 PDT
https://hg.mozilla.org/comm-central/rev/3c1dbcbd0e112ce03e69da5d77da38b48ef83974
Bug 1192600 - create deterministic header list ical.h. r=philipp

Note You need to log in before you can comment on or make changes to this bug.