Closed Bug 1192601 Opened 5 years ago Closed 5 years ago

WARNING: content window passed to PrivateBrowsingUtils.isWindowPrivate. Use isContentWindowPrivate instead (but only for frame scripts).

Categories

(Firefox :: General, defect)

39 Branch
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 1193527

People

(Reporter: ml, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Fedora; Linux i686; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150806132821

Steps to reproduce:

Steps:
1. Start Firefox from the command line
2. Load "about:privatebrowsing" via the locationbar
3. Observe the warnings in the terminal

> firefox
(firefox:12594): GLib-GObject-WARNING **: The property GtkSettings:gtk-menu-images is deprecated and shouldn't be used anymore. It will be removed in a future version.
WARNING: content window passed to PrivateBrowsingUtils.isWindowPrivate. Use isContentWindowPrivate instead (but only for frame scripts).
pbu_isWindowPrivate@resource://gre/modules/PrivateBrowsingUtils.jsm:25:14
nsBrowserAccess.prototype.openURI@chrome://browser/content/browser.js:15418:21

2015 08 09 
Linux localhost.localdomain 4.1.3-201.fc22.i686+PAE #1 SMP Wed Jul 29 20:36:37 UTC 2015 i686 i686 i386 GNU/Linux (Fedora 22)
Mozilla Firefox 39.0.3

is there to be fixed?
Severity: normal → minor
I can't reproduce on current nightly on OS X. Can you reproduce with a nightly build with a new profile?
Component: Untriaged → Private Browsing
This would be the fault of the caller in nsBrowserAccess.
Component: Private Browsing → General
Status: UNCONFIRMED → NEW
Ever confirmed: true
@Nickolay. I am not knowledgeable, how do I install nightly build (without to lose any data). I am on Fedora 22. 

# firefox -ProfileManager (new, empty profile)

(firefox:9096): GLib-GObject-WARNING **: The property GtkSettings:gtk-menu-images is deprecated and shouldn't be used anymore. It will be removed in a future version.
[VS] Software VDPAU backend library initialized
libva info: VA-API version 0.37.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/dri/i915_drv_video.so
libva info: va_openDriver() returns -1
WARNING: content window passed to PrivateBrowsingUtils.isWindowPrivate. Use isContentWindowPrivate instead (but only for frame scripts).
pbu_isWindowPrivate@resource://gre/modules/PrivateBrowsingUtils.jsm:25:14
nsBrowserAccess.prototype.openURI@chrome://browser/content/browser.js:15418:21
1439200214310	addons.update-checker	WARN	Update manifest for {972ce4c6-7e08-4474-a285-3208198ce6fd} did not contain an updates property
.....
Can confirm on version 40.0.2 (stable), but not on 43.0a1 (2015-08-24) (Nightly). Debian Stretch, x86-64.

Shall we say it's fixed, then?
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1193527
On Fedora 22,  i686, v 40.0.3, it is gone. Fine, Thanks.

ps Instead I get some warning on firebug (and command line?):

1440925798309	addons.xpi	WARN	Exception running bootstrap method startup on firebug@software.joehewitt.com: TypeError: scope.gcli.addItems is not a function (resource://firebug/gcli.js:129) JS Stack trace: addCommand@gcli.js:129:1 < registerCommands@gcli.js:135:1 < FirebugGCLICommands.startup@gcli.js:45:9 < startup@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///root/.mozilla/firefox/lqg22dhd.default-1438786328413/extensions/firebug@bootstrap.js:78:5 < XPI_callBootstrapMethod@XPIProvider.jsm:4639:9 < XPI_startup@XPIProvider.jsm:2358:13 < callProvider@AddonManager.jsm:221:12 < _startProvider@AddonManager.jsm:828:5 < AMI_startup@AddonManager.jsm:996:9 < AMP_startup@AddonManager.jsm:2656:5 < AMC_observe@addonManager.js:55:7
You need to log in before you can comment on or make changes to this bug.