In the Applications in-content preferences, fix the Ctrl/Cmd+f and Ctrl/Cmd+k keys to focus the search box

VERIFIED FIXED in Firefox 43

Status

()

VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: steffen.wilberg, Assigned: steffen.wilberg)

Tracking

(Blocks: 1 bug, {regression})

Trunk
Firefox 43
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox42 affected, firefox43 verified)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
In the in-content preferences, Applications pane, the keys to focus the Search box (Ctrl/Cmd+f and Ctrl/Cmd+k) are broken.
Accel+f now invokes the find bar instead, which is useless.

This is a regression from bug 1016300, which removed the oncommand attribute from the <key> elements. This doesn't work because of bug 371900.

The fix is to add |oncommand=";"| to the <key> elements.
Bug 978115 is on file to clean up these workarounds once bug 371900 is fixed.
(Assignee)

Comment 1

3 years ago
Created attachment 8645435 [details] [diff] [review]
In the Applications in-content preferences, fix the Ctrl/Cmd+f and Ctrl/Cmd+k keys to focus the search box
(Assignee)

Updated

3 years ago
Attachment #8645435 - Flags: review?(gijskruitbosch+bugs)

Comment 2

3 years ago
Comment on attachment 8645435 [details] [diff] [review]
In the Applications in-content preferences, fix the Ctrl/Cmd+f and Ctrl/Cmd+k keys to focus the search box

Review of attachment 8645435 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for the super-clear explanation in comment #0. Wish all bugs came with descriptions that good.

Maybe leave a code comment (<!-- ... -->) before these two <key>s so we don't accidentally remove them again - something like "oncommand attributes are here because of bug 371900"?
Attachment #8645435 - Flags: review?(gijskruitbosch+bugs) → review+

Comment 4

3 years ago
(In reply to :Gijs Kruitbosch from comment #2)
> Maybe leave a code comment (<!-- ... -->) before these two <key>s so we
> don't accidentally remove them again - something like "oncommand attributes
> are here because of bug 371900"?

(In reply to Pulsebot from comment #3)
> https://hg.mozilla.org/integration/fx-team/rev/aac05e8ce3ec

I should really not land things without having tea in the morning.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/aac05e8ce3ec
https://hg.mozilla.org/mozilla-central/rev/6509f5665152
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox43: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 43
QA Whiteboard: [good first verify]
I have reproduced this bug on Nightly 42.0a1 (2015-08-09) on ubuntu 14.04 LTS, 32 bit!

The bug's fix is now verified on Latest Beta 43.0b3!

Build ID: 20151112144305
User Agent: Mozilla/5.0 (X11; Linux i686; rv:43.0) Gecko/20100101 Firefox/43.0

[testday-20151113]

Updated

3 years ago
Status: RESOLVED → VERIFIED
status-firefox43: fixed → verified
(Assignee)

Updated

2 years ago
Depends on: 1326821
You need to log in before you can comment on or make changes to this bug.