Nightly not on Start-Menu frequently used list

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: Jim Jeffery not reading bug-mail 1/2/11, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(firefox42 affected)

Details

Starting in cset: https://hg.mozilla.org/mozilla-central/pushloghtml?changeset=fd63d8ed9d2e 

Install above cset
Press Windows Key or click on Start-Orb
Note that Nightly is not on the Frequent used list, should be on first page if you use it a lot.  
Also note that the Flyout Frequent sites is missing, once you find Nightly on the list.  I have to go to 'all programs', then its in alphabetical list as if used 'infrequently' 

Testing on win7 x64 win32 builds from m-c
Cset range:

https://hg.mozilla.org/integration/fx-team/rev/799742085c18 Good
https://hg.mozilla.org/integration/fx-team/rev/152eafb9dc89  Bad
https://bugzilla.mozilla.org/show_bug.cgi?id=1175606

Bug 1175606 appears to have been backed out twice, but I'm not sure the backout made it into m-c, though Treeherder shows the entry for the backout..

I'm confused - Anyone can verify the range ?
Regression range from m-c

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d263ff7885e9&tochange=fd63d8ed9d2e
Blocks: 1175606
(In reply to Jim Jeffery not reading bug-mail 1/2/11 from comment #1)
> Cset range:
> 
> https://hg.mozilla.org/integration/fx-team/rev/799742085c18 Good
> https://hg.mozilla.org/integration/fx-team/rev/152eafb9dc89  Bad
> https://bugzilla.mozilla.org/show_bug.cgi?id=1175606
> 
> Bug 1175606 appears to have been backed out twice, but I'm not sure the
> backout made it into m-c, though Treeherder shows the entry for the backout..

Bug 1175606 hasn't hit m-c without being backed out.

Original commit: https://hg.mozilla.org/integration/fx-team/rev/f6a62807987d, which was backed out: https://hg.mozilla.org/integration/fx-team/rev/152eafb9dc89

Second commit: https://hg.mozilla.org/integration/fx-team/rev/023218047be5, which was backed out: https://hg.mozilla.org/integration/fx-team/rev/c56e7866445c.

Third commit (which hasn't hit m-c): https://hg.mozilla.org/integration/fx-team/rev/dc44b9a3b542.

Anyway, it seems very unlikely that it would have anything to do with the Windows start menu (it's a frontend only change that's flipping a few prefs).  Worth looking through the m-c regression range in Comment 2 for other likely offenders
Just confirmed on a clean profile in the latest Nightly (2015-08-09) that the functionality from Bug 1175606 hasn't hit.  Are you seeing this in Nightly also or only a build from that cset?
Flags: needinfo?(jmjeffery)
Color me totally confused at this point.  Sorry.

I do not see the issue in today's Nightly.

I first noticed it when I installed tinderbox build based on same cset at today's Nightly.
cset:https://hg.mozilla.org/mozilla-central/rev/24f4d8e5e24b

I then installed cset in comment #0 and saw the problem.
I then installed the tinderbox cset prior to one in comment #0 and the problem went away.

I started testing fx builds because that the was the merge fx->m-c

I've since tested and retested and today's Nightly does not have the issue.
I can install comment #0 and the issue returns.

So I'm really confused, but at this point I guess we can close this INVALID and release the block I placed on bug 1175606.

Some pointer is not being updated either in my system, or the sequence of installing and testing multiple builds looking for a regression range.  I've seen things in past that once a problem is found that it will carry on through several builds when testing looking for the issue only to have it clear and leave things in a state of 'confusion', at least to me. 

I hope this makes some sense.
No longer blocks: 1175606
Flags: needinfo?(jmjeffery)
I just re-tested again, and the issue is present if I install the cset noted in comment #0

That cset was a merge from fx-team -> m-c

I then installed cset https://hg.mozilla.org/mozilla-central/rev/24f4d8e5e24b from the tinderbox (hourly builds) and the issue remained.

I then installed today's Nightly based on the same cset and the issue if fixed.

So.. some patch inthe cset from comment #0 is causing this problem.  

I'm wondering now if bug 1175606 needed a 'clobber' when it was backed out, and still could be the reason for this problem?
OK, bug 1175606 just landed in latest m-c hourly(tinderbox build) as cset:
https://hg.mozilla.org/mozilla-central/rev/a431fb8b9a40

The Nightly is missing from the Frequent used list on the Win7 Start Menu.

I guess we wait now till tomorrow's Nightly, which are clobber builds, and see if the Nightly Icon returns to the top of the Windows Start Menu.
Blocks: 1175606
Testing in today's Nightly build the Nightly Icon appears now in the Most Frequent list from the Win7 Start Orb. 

Appears to me that whenever this patch is backed out or landed that it needs a clobber to fully activate/deactivate the changes in this patch.  

As to why its affecting the Start Menu Frequently used list is beyond my understanding.

Marking this bug now as WFM.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.