Closed Bug 1192686 Opened 5 years ago Closed 5 years ago

"var(--downloads-indicator-icon) center no-repeat" Invalid Variable

Categories

(Firefox :: Theme, defect)

40 Branch
x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 43
Tracking Status
firefox41 --- fixed
firefox42 --- fixed
firefox43 --- fixed

People

(Reporter: mvocom, Assigned: Gijs)

References

Details

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150807085045

Steps to reproduce:

Press the Download icon.


Actual results:

Multiple warnings:

"var(--downloads-indicator-icon) center no-repeat" Property contained reference to invalid variable.
chrome://browser/skin/browser.css 5397, 178616
Hi Gijs,

Could you please have a look?
Flags: needinfo?(gijskruitbosch+bugs)
D'oh.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(gijskruitbosch+bugs)
Attachment #8647489 - Flags: review?(dao)
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
downloads-indicator-icon is a child of downloads-button, so setting the variable on downloads-button only should be sufficient, right?
Thank you Gijs.
Can you think of someone who may work on Bug 1182360?
Comment on attachment 8647489 [details] [diff] [review]
fix downloads variable warning on Windows,

I think you're right, but I need to test this, and that will need to wait until tomorrow.
Attachment #8647489 - Flags: review?(dao)
Component: Untriaged → Theme
OS: Unspecified → Windows 7
Hardware: Unspecified → x86
Attached patch Patch v2Splinter Review
Attachment #8647489 - Attachment is obsolete: true
Attachment #8648768 - Flags: review?(dao)
Attachment #8648768 - Flags: review?(dao) → review+
https://hg.mozilla.org/mozilla-central/rev/5161d574297a
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 43
Thanks again Gijs.

May I ask your help with Bug 1195552?

I'd appreciate it.
Blocks: 1153529
Comment on attachment 8648768 [details] [diff] [review]
Patch v2

Approval Request Comment
[Feature/regressing bug #]: bug 1153529
[User impact if declined]: CSS warnings in the browser console, possibly unintended styling
[Describe test coverage new/current, TreeHerder]: nope...
[Risks and why]: very low, 2-line correctness fix in some CSS
[String/UUID change made/needed]: no
Attachment #8648768 - Flags: approval-mozilla-beta?
Attachment #8648768 - Flags: approval-mozilla-aurora?
Comment on attachment 8648768 [details] [diff] [review]
Patch v2

Simple enough, let's uplift to Beta and Aurora.
Attachment #8648768 - Flags: approval-mozilla-beta?
Attachment #8648768 - Flags: approval-mozilla-beta+
Attachment #8648768 - Flags: approval-mozilla-aurora?
Attachment #8648768 - Flags: approval-mozilla-aurora+
Duplicate of this bug: 1197341
You need to log in before you can comment on or make changes to this bug.