[linux] firefox status tooltips (for links) have wrong foreground color (and end up being illegible)

RESOLVED WORKSFORME

Status

()

Firefox
Theme
RESOLVED WORKSFORME
2 years ago
a year ago

People

(Reporter: muesli4, Unassigned)

Tracking

39 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8645617 [details]
firefox-status-bar-text-color-bug.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150807021757

Steps to reproduce:

I'm using firefox with a GTK2/3 Theme (I think it actually uses GTK2) and the theme specifies a dark color for the background (black) and a light color for the foreground (white).


Actual results:

Firefox displays the status bar with the wrong font color, which is black on black.


Expected results:

Firefox should display the status bar with a white font color (the one used for tooltip text in GTK).

I added a screenshot, which shows the behaviour (the mouseover for Bugzilla@Mozilla actuallly shows the way it should look and on the bottom of the screen how it should not look: all black).
(Reporter)

Updated

2 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Updated

2 years ago
Component: Untriaged → Widget: Gtk
Product: Firefox → Core

Updated

a year ago
Component: Widget: Gtk → Theme
Product: Core → Firefox

Comment 1

a year ago
Can you still reproduce this issue now that we're using gtk3? This wfm on a dark theme with the current gtk3-based Firefox on ubuntu.
Flags: needinfo?(muesli4)
Summary: firefox status bar has wrong font color → [linux] firefox status tooltips (for links) have wrong foreground color (and end up being illegible)
(Reporter)

Comment 2

a year ago
No, I think it is related to the gtk2 version, the status bar is perfectly readable (although not exactly matching with the theme, but I guess that is not of much importance).

Comment 3

a year ago
OK, marking "works for me" then, and we can reopen if/when this happens again. Thanks for getting back to us so quickly!
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(muesli4)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.