[Meta] Raptor/Profiler Integration

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: bobby.chien+bugzilla, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:backlog)

Details

(Whiteboard: [perf-wanted])

(Reporter)

Description

3 years ago
As a developer, I usually need to use Gecko profiler (or others profiling tools)
to help out solving performance bugs, to run it while Raptor is
running may reduce development works. Moreover, if the process is
automatic, we're also apt to collect more profiling data than doing it
manually.

The proposal is to implement a simple script at early stage: the
script only needs to start Raptor and profiler at the same time, which
can be done with two shell commands. We also need to stop the profiler
with captured data at the end of Raptor test, although this part I
don't think it's easy to be implemented with pure shellscript. There
are still lots of details to clarify, but I think If we can get this
work well, with valuable profiled data and the workflow is simpler
than previous, we may take a look to see how to push it in the future.

The major difficulty is Gecko profiler needs some special flags for
profiling bootstrapping performance, and to profile the device during
a specific period with clear markers from Raptor. Other issues include
how to set an option to turn this feature on/off dynamically (since in
some cases we needn't profiling), and how to collect the data and even
display it on remote server properly. But if people think this would
help us to diagnose performance issues in the future, I think we
should consider to turn it on for automation tests. For example, it
can be suspend at rural integration tests, but if any performance
regression is triggered, it should re-run the test with profiling
enabled.
(Reporter)

Comment 1

3 years ago
[Tracking Requested - why for this release]:
Blocks: 1133421
tracking-b2g: --- → backlog
Summary: Raptor/Profiler Integration → [Meta] Raptor/Profiler Integration

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.