Can't see visible action when I click "Change Search Settings" if about:preferences#search is already opened

VERIFIED FIXED in Firefox 43

Status

()

defect
P4
normal
Rank:
45
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: arni2033, Assigned: florian)

Tracking

Trunk
Firefox 43
Points:
---

Firefox Tracking Flags

(firefox43 verified)

Details

(Whiteboard: [fxsearch])

Attachments

(1 attachment)

Reporter

Description

4 years ago
STR:
1.   Open about:preferences#search
2.A) Click dropmarker in location bar
2.B) Click dropmarker in search bar
3.   Click button "Change Search Settings"

RESULT:       Nothing happens
Expectations: Drop-down list should hide to show preferences page
Reporter

Updated

4 years ago
Summary: Can't see visible action when I click "Change Search Settings" → Can't see visible action when I click "Change Search Settings" if about:preferences#search is opened
Reporter

Updated

4 years ago
Component: Preferences → Location Bar
Summary: Can't see visible action when I click "Change Search Settings" if about:preferences#search is opened → Can't see visible action when I click "Change Search Settings" if about:preferences#search is already opened
Reporter

Updated

4 years ago
not blocking unified complete since this is not even part of it, it's related to one-click searches UI (bug 1180944).
I agree the dropdown should be closed regardless.
Priority: -- → P3
Whiteboard: [fxsearch]
No longer blocks: UnifiedComplete

Updated

4 years ago
Rank: 45
Priority: P3 → P4
Assignee

Comment 2

4 years ago
Posted patch PatchSplinter Review
Assignee: nobody → florian
Attachment #8661203 - Flags: review?(gijskruitbosch+bugs)

Comment 3

4 years ago
Comment on attachment 8661203 [details] [diff] [review]
Patch

Review of attachment 8661203 [details] [diff] [review]:
-----------------------------------------------------------------

rs=me
Attachment #8661203 - Flags: review?(gijskruitbosch+bugs) → review+
https://hg.mozilla.org/mozilla-central/rev/e5658e0e9c6d
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 43
Reporter

Comment 6

4 years ago
Er... I actually expected something better than that, e.g. some transitioning highlight indicating that the panel not only disappeared (may be perceived as a bug), but the user is already on the right page, and can actually start changing search settings.

Well, anyway, I'm not going to file (almost) the same report again; plus that feature would require some additional designer's work.
Reproduced this bug by following comment 0 with Firefox Nightly 42.0a1 (2015-08-10); 
(Build ID: 20150810030205) on Linux, 64 Bit

This Bug is now verified as fixed on Latest Firefox Beta 43.0b7

Build ID 	20151126120800
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0
QA Whiteboard: [testday-20151127]
Reproduced this bug by following comment 0 with Firefox Nightly 42.0a1 (2015-08-10); 
(Build ID: 20150810030205; User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:42.0) Gecko/20100101 Firefox/42.0) on Windows 8.1, 64 Bit

This Bug is now verified as fixed on Latest Firefox Beta 43.0b7

Build ID 	20151126120800
User Agent 	Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:43.0) Gecko/20100101 Firefox/43.0


As per comment 7, changing the status as verified fixed.
Status: RESOLVED → VERIFIED
Reporter

Updated

3 years ago
Has STR: --- → yes
You need to log in before you can comment on or make changes to this bug.