Remove PlayPreview API

RESOLVED FIXED in Firefox 43

Status

()

Core
Plug-ins
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: yury, Assigned: yury, NeedInfo)

Tracking

Trunk
mozilla43
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox43 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

3 years ago
This will make bug 558184 smaller. We arealready changing two its known users (PDF Viewer and Shumway) to not use the API, so we can remove the API itself.
(Assignee)

Comment 1

3 years ago
Created attachment 8649556 [details] [diff] [review]
Remove PlayPreview API

Based on the Part 5 patch from bug 1186577 (or bug 558184): rebased and removal another PlayPreview test included.
(Assignee)

Updated

3 years ago
Attachment #8649556 - Flags: review?(bugs)

Comment 2

3 years ago
Comment on attachment 8649556 [details] [diff] [review]
Remove PlayPreview API

Review of attachment 8649556 [details] [diff] [review]:
-----------------------------------------------------------------

r=me based on these patches basically using identical code used in jsplugins to remove this API
Attachment #8649556 - Flags: review?(bugs) → review+

Comment 3

3 years ago
Leaving a NI? for PeterV to look at bug 1186577 again after this lands.
Flags: needinfo?(peterv)
(Assignee)

Comment 4

3 years ago
Created attachment 8650753 [details] [diff] [review]
Remove PlayPreview API

(Updated uuid in nsPluginsHost.idl)

https://treeherder.mozilla.org/#/jobs?repo=try&revision=9c086584b222
Attachment #8649556 - Attachment is obsolete: true
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
webidl changes need DOM peer review
Keywords: checkin-needed
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
Backed out for suspicion of being the cause of the big spike in bug 1178709 on Windows 8. I'll re-land if that turns out to not be the case.
https://hg.mozilla.org/integration/mozilla-inbound/rev/23649438b3bb
Confirmed fixed by backout.
(Assignee)

Updated

2 years ago
Blocks: 1148827
(Assignee)

Updated

2 years ago
Depends on: 1178709
https://hg.mozilla.org/mozilla-central/rev/073c612673cf
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox43: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
Duplicate of this bug: 1221692
You need to log in before you can comment on or make changes to this bug.