[sync] Do not delete translations

RESOLVED DUPLICATE of bug 1288956

Status

P3
normal
RESOLVED DUPLICATE of bug 1288956
3 years ago
2 years ago

People

(Reporter: mathjazz, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox43 affected)

Details

(Reporter)

Description

3 years ago
Translations of obsolete entities should be kept. We use them in Translation memory. Here's why:

1. We have a string "Inspector".
2. Slovenian translation is submitted: "Pregledovalnik".
3. Original string is replaced with "DOM Inspector".
4. We want to show "Pregledovalnik" as suggestion from Translation memory.
(Reporter)

Updated

3 years ago
Summary: Do not delete translations on Sync → [sync] Do not delete translations
(Reporter)

Updated

3 years ago
Priority: -- → P1
:mathjazz do you intend to work on this or can i try to solve this problem?
(Reporter)

Comment 2

3 years ago
Feel free to take it.
Assignee: nobody → jot

Comment 3

3 years ago
Commit pushed to master at https://github.com/mozilla/pontoon

https://github.com/mozilla/pontoon/commit/9d62c104fe15c79a8c20ebe033f60bf898cb97fd
Fix bug 1192872: Added separate model for translation memory entries and moved calculations of levenshtein.ratio() to the database.

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

3 years ago
Wrong bug number.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 5

3 years ago
The problem with translation memory not keeping deleted translations is fixed:
https://github.com/mozilla/pontoon/commit/9d62c104fe15c79a8c20ebe033f60bf898cb97fd

We should still keep translations (and mark them as deleted instead of actually deleting them), because we'll need them for statistics and user timeline.

Lowering priority.
Priority: P1 → P3
Assignee: jot → nobody
(Reporter)

Updated

2 years ago
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1288956
You need to log in before you can comment on or make changes to this bug.