Closed Bug 1192973 Opened 4 years ago Closed 4 years ago

[Marketplace] Settings options become unresponsive when WiFi and Data is disabled.

Categories

(Marketplace Graveyard :: General, defect, P2)

Avenir
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1177847

People

(Reporter: jthomas, Assigned: mat)

References

()

Details

(Whiteboard: [2.5-Daily-Testing][Spark])

Attachments

(1 file)

Description: If the settings menu is open in Marketplace and Wifi or Data is disabled some of the buttons such as "Sign In" and "Register" become unresponsive. Outside of this menu the user is also able to attempt a search with no results or a prompt saying no connection is available.

Repro Steps:
1) Update a Aries to 20150810142756
2) Enable Wi-Fi or Data enabled.
3) Open Marketplace.
4) Select drawer button to open settings.
5) Disable Wifi and Data
6) From Marketplace settings select Sign In, Register.

Actual:
Sign In, Register buttons become unresponsive.

Expected:
It is expected that the user will receive a message indicating that a connection is needed before these button functionalities can be applied.

Environmental Variables:
Device: Aries 2.5 Kk
Build ID: 20150810142756
Gaia: fa89e03dc489e79baa0e74cb1d205260c7924caa
Gecko: cd45a38ded04
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0


User Impact: User may be confused as to why some of the Marketplace features have become unresponsive or why a search is not containing any results.

Repro frequency: 100%
See attached: Logcat & Video
Video: https://youtu.be/3UBUm3qkOCg
This issue is reproducing on Flame 2.5 and 2.2. 

Result: Sign In, Register buttons become unresponsive.

Environmental Variables:
Device: Flame 2.5 KK Fullflash (319mb)
Build ID: 20150810053007
Gaia: fa89e03dc489e79baa0e74cb1d205260c7924caa
Gecko: cd45a38ded04
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 42.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Environmental Variables:
Device: Flame 2.2 KK Fullflash (319mb)
BuildID: 20150807003005
Gaia: 102f1299e9eafe3760e1deb44d556b5c4f36b5af
Gecko: da29b5af4232
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Environmental Variables:
Device: Flame 2.2 KK Fullflash (319mb)
Build ID: 20150807003005
Gaia: 102f1299e9eafe3760e1deb44d556b5c4f36b5af
Gecko: da29b5af4232
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Whiteboard: [2.5-Daily-Testing][Spark]
Assignee: nobody → mpillard
Priority: -- → P2
See Also: → 1178423
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
This is essentially bug 1177847. We don't currently detect network connection loss, and we should.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1177847
You need to log in before you can comment on or make changes to this bug.