Closed Bug 1193040 Opened 4 years ago Closed 4 years ago

[debug M(2, p)] failures due to assertions on windows 10

Categories

(Testing :: Mochitest, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Callek, Unassigned)

References

Details

https://treeherder.mozilla.org/logviewer.html#?job_id=10282075&repo=try

Dolske, anyone you can suggest to look into this.

Most of the failed assertions seem to be of the pattern:

INFO -  [4080] ###!!! ASSERTION: Given time appears to be in the future: 'aTime <= TimeStamp::Now()', file c:/builds/moz2_slave/try-w64-d-00000000000000000000/build/src/image/FrameAnimator.cpp, line 81


3 INFO TEST-UNEXPECTED-ERROR | dom/push/test/test_has_permissions.html | Assertion count 46 is greater than expected range 0-0 assertions.
8 INFO TEST-UNEXPECTED-ERROR | dom/push/test/test_multiple_register_different_scope.html | Assertion count 5 is greater than expected range 0-0 assertions.
11 INFO TEST-UNEXPECTED-ERROR | dom/push/test/test_multiple_register_during_service_activation.html | Assertion count 7 is greater than expected range 0-0 assertions.
14 INFO TEST-UNEXPECTED-ERROR | dom/push/test/test_permissions.html | Assertion count 7 is greater than expected range 0-0 assertions.
17 INFO TEST-UNEXPECTED-ERROR | dom/push/test/test_push_manager_worker.html | Assertion count 6 is greater than expected range 0-0 assertions.
20 INFO TEST-UNEXPECTED-ERROR | dom/push/test/test_register.html | Assertion count 11 is greater than expected range 0-0 assertions.
23 INFO TEST-UNEXPECTED-ERROR | dom/push/test/test_try_registering_offline_disabled.html | Assertion count 8 is greater than expected range 0-0 assertions.
26 INFO TEST-UNEXPECTED-ERROR | dom/push/test/test_unregister.html | Assertion count 9 is greater than expected range 0-0 assertions.

Per logging in just now it appears the system time is set correctly, in PT, just like our existing w8 machines
Flags: needinfo?(dolske)
Sounds like bug 1190257.
Depends on: 1190257
thanks to dmajor, we may have our culprit
Flags: needinfo?(dolske)
Same assert is breaking a handful of M(2) tests. (I'll just update here once the full run is done, instead of a play-by-play)
Summary: [debug M(p)] failures due to assertions on windows 10 → [debug M(2, p)] failures due to assertions on windows 10
To be clear, this was a lot of tests, however Bug 1193040 had a try run I threw against win10 that seems to fix this assertion issue....
dep bug is fixed, any further assertions of this type will be a different issue, and less prolific
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.