Add option to build without Shumway

RESOLVED DUPLICATE of bug 1193141

Status

RESOLVED DUPLICATE of bug 1193141
3 years ago
21 days ago

People

(Reporter: qfxqfx7, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
There should be a configure flag (e.g. "--disable-shumway") to compile Firefox without Shumway.

Many users try to compile custom, minimal versions and hand-patching the codebase is cumbersome and has to be updated with each Firefox release.
There kind of already exists an option under which this should all fall: --enable-extensions, which allows to selectively enable/disable some kinds of extensions (those in the extensions top directory).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1193141
Component: Build Config → General
Product: Firefox → Firefox Build System
You need to log in before you can comment on or make changes to this bug.