Closed Bug 1193201 Opened 4 years ago Closed 4 years ago

browser/config/version_display.txt is incorrect in nightly & aurora

Categories

(Release Engineering :: Release Automation: Other, defect)

defect
Not set

Tracking

(firefox42 fixed, firefox43 fixed)

RESOLVED FIXED
Tracking Status
firefox42 --- fixed
firefox43 --- fixed

People

(Reporter: Sylvestre, Assigned: Sylvestre)

References

Details

Attachments

(2 files)

Attached patch foo.diffSplinter Review
<avaida> does anyone know why Aurora 42.0a2 is currently showing "42.0a1" as its build version?
We should have 42.0a2 and not 42.0a1

This is probably caused by bug 1175331 not landing in time.
Attachment #8646233 - Flags: review?(nthomas)
Attachment #8646233 - Flags: review?(nthomas) → review+
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
This needs to be fixed in mozilla-central as well.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Summary: browser/config/version_display.txt is incorrect in aurora → browser/config/version_display.txt is incorrect in nightly & aurora
Attachment #8646310 - Flags: review?(bhearsum)
Comment on attachment 8646310 [details] [diff] [review]
fix-version-nightly

Review of attachment 8646310 [details] [diff] [review]:
-----------------------------------------------------------------

Naively, I thought that this number would be sourced from the "true" application version.
Attachment #8646310 - Flags: review?(bhearsum) → review+
Myself, I thought that this number would be updated during merge day :)

https://hg.mozilla.org/integration/mozilla-inbound/rev/e158708d4ca3
https://hg.mozilla.org/mozilla-central/rev/e158708d4ca3
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
Just wondering would it be smarter to change the code to display version_display.txt if it exists otherwise display version.txt and only have a version_display.txt on the beta branch?
Flags: needinfo?(sledru)
Duplicate of this bug: 1193604
Bill, not sure that having a file existing only in a specific branch is the best solution. :/
Flags: needinfo?(sledru)
You need to log in before you can comment on or make changes to this bug.