Closed Bug 1193206 Opened 4 years ago Closed 4 years ago

Build with Android support library 23

Categories

(Firefox Build System :: Android Studio and Gradle Integration, defect)

All
Android
defect
Not set

Tracking

(firefox43 affected, firefox44 fixed)

RESOLVED FIXED
mozilla44
Tracking Status
firefox43 --- affected
firefox44 --- fixed

People

(Reporter: sebastian, Assigned: sebastian)

References

Details

Attachments

(2 files)

Support library 23 will give us all the goodies needed to use some of the Android M features in a backwards compatible way.
Depends on: 1195691
We'll need to build against API 23 to use the new support library, see bug 1195691.
Depends on: build-android-m
Duplicate of this bug: 1205963
Bug 1210755 / Bug 1197147 / Bug 1193206 - Update releng.manifest to use latest SDK and tools. r=trivial default tip 
https://hg.mozilla.org/integration/fx-team/rev/f3cb1dd809ff
Assignee: nobody → s.kaspari
Status: NEW → ASSIGNED
Depends on: 1211467
Attachment #8669844 - Flags: review?(nalexander)
Comment on attachment 8669844 [details] [diff] [review]
1193206-support-library.patch

Review of attachment 8669844 [details] [diff] [review]:
-----------------------------------------------------------------

If it works for you, it works for me!
Attachment #8669844 - Flags: review?(nalexander) → review+
I'm seeing weird dex errors. This requires a CLOBBER.
(In reply to Sebastian Kaspari (:sebastian) from comment #8)
> Created attachment 8670259 [details] [diff] [review]
> 1193206-CLOBBER.patch
> 
> I'm seeing weird dex errors. This requires a CLOBBER.

All try builds are clobber builds, for historical reasons.  If you're seeing build failures with DEX errors on try, it's probably not due to clobber needed.
(In reply to Nick Alexander :nalexander from comment #10)
> (In reply to Sebastian Kaspari (:sebastian) from comment #8)
> > Created attachment 8670259 [details] [diff] [review]
> > 1193206-CLOBBER.patch
> > 
> > I'm seeing weird dex errors. This requires a CLOBBER.
> 
> All try builds are clobber builds, for historical reasons.  If you're seeing
> build failures with DEX errors on try, it's probably not due to clobber
> needed.

Oh, this is not related to try. I just saw them locally.
https://hg.mozilla.org/mozilla-central/rev/735d8bed131d
https://hg.mozilla.org/mozilla-central/rev/d823b6f2f8d2
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 44
Product: Firefox for Android → Firefox Build System
Target Milestone: Firefox 44 → mozilla44
You need to log in before you can comment on or make changes to this bug.