[basket] Please push tag to stage then prod.

VERIFIED FIXED

Status

Infrastructure & Operations Graveyard
WebOps: Product Delivery
VERIFIED FIXED
2 years ago
a year ago

People

(Reporter: pmac, Assigned: cyliang)

Tracking

Details

(Whiteboard: [kanban:https://webops.kanbanize.com/ctrl_board/2/1539] )

Please push the tag "v2015.5" to stage, then after we've tested and verified, prod.

We're in an odd place at the moment though because dev and stage are on the new Python 2.7 generic cluster, but prod is still on the old one. Hopefully this isn't an issue, but that's the deal as far as I understand it at the moment.

Updated

2 years ago
Whiteboard: [kanban:https://webops.kanbanize.com/ctrl_board/2/1539]
(Assignee)

Updated

2 years ago
Assignee: server-ops-webops → cliang
(Assignee)

Comment 1

2 years ago
Flagging that the stage is on the new python generic cluster was helpful.  Thanks.

I've pushed the code out to stage and restarted the Apache processes on the webheads.  Please let me know when / if we're ready for a push to -prod.


$ pwd
/data/python-stage/src/basket.allizom.org
$ sudo bash ./update v2015.5
[2015-08-11 17:52:43] Updating code.
commit 2634d4c983f10a87cf49ec48b0c46c9c37cc2d62
Merge: 034a156 b90c222
Author: Paul McLanahan <pmac@mozilla.com>
Date:   Mon Aug 10 10:04:26 2015 -0400

    Merge pull request #143 from pmclanahan/add-accept-lang-subscribe-1188047

    Fix bug 1188047: Add accept_lang support to subscribe.

commit b90c22208d528e803150c44170a64df1b0137020
Author: Paul McLanahan <pmac@mozilla.com>
Date:   Tue Jul 28 14:48:13 2015 -0400

    Fix bug 1188047: Add accept_lang support to subscribe.

    Also updates get_best_language to also search for 2 letter
    languages in our supported list.

commit 034a156c3f87ec5b8efa98f6f781b4959786adc2
Merge: 8573515 c5b18e2
Author: Josh Mize <jgmize@gmail.com>
Date:   Wed Jul 22 01:57:59 2015 -0500

    Merge pull request #139 from pmclanahan/fix-look-for-user-1185999

    Fix bug 1185999: Look up users in Confirmed DE properly.
[2015-08-11 17:52:44] Updating vendor.
[2015-08-11 17:52:45] Collect static assets.
[2015-08-11 17:52:47] Sync & migrate database.
/data/python-stage/src/basket.allizom.org/basket/vendor/packages/django-picklefield/src/picklefield/compat.py:13: DeprecationWarning: django.utils.simplejson is deprecated; use json instead.
  from django.utils import simplejson as json
Syncing...
Creating tables ...
Installing custom SQL ...
Installing indexes ...
Installed 0 object(s) from 0 fixture(s)

Synced:
 > corsheaders
 > south
 > raven.contrib.django.raven_compat
 > django.contrib.auth
 > django.contrib.contenttypes
 > django.contrib.sessions
 > django.contrib.sites
 > django.contrib.messages
 > django.contrib.admin
 > django.contrib.staticfiles

Not synced (use migrations):
 - news
 - djcelery
(use ./manage.py migrate to migrate these)
/data/python-stage/src/basket.allizom.org/basket/vendor/packages/django-picklefield/src/picklefield/compat.py:13: DeprecationWarning: django.utils.simplejson is deprecated; use json instead.
  from django.utils import simplejson as json
Running migrations for news:
- Nothing to migrate.
 - Loading initial data for news.
Installed 0 object(s) from 0 fixture(s)
Running migrations for djcelery:
- Nothing to migrate.
 - Loading initial data for djcelery.
Installed 0 object(s) from 0 fixture(s)
[2015-08-11 17:52:49] Clean up old deploy.
[2015-08-11 17:52:51] Deploying.
All seems to be working well. You're clear for the push to prod, but let's wait until the morning (pacific) as it's late where I am and I'd like to be around when it happens.

Thanks again!
(Assignee)

Comment 3

2 years ago
Pushed to prod.  FWIW, the celery restart took about 10 minutes on one of the nodes (generic-celery1.webapp.phx1); on the other nodes, the restart went pretty quickly.


$ pwd
/data/genericrhel6/src/basket.mozilla.org
$ sudo bash ./update v2015.5
[2015-08-12 15:06:33] Updating code.
commit 2634d4c983f10a87cf49ec48b0c46c9c37cc2d62
Merge: 034a156 b90c222
Author: Paul McLanahan <pmac@mozilla.com>
Date:   Mon Aug 10 10:04:26 2015 -0400

    Merge pull request #143 from pmclanahan/add-accept-lang-subscribe-1188047

    Fix bug 1188047: Add accept_lang support to subscribe.

commit b90c22208d528e803150c44170a64df1b0137020
Author: Paul McLanahan <pmac@mozilla.com>
Date:   Tue Jul 28 14:48:13 2015 -0400

    Fix bug 1188047: Add accept_lang support to subscribe.

    Also updates get_best_language to also search for 2 letter
    languages in our supported list.

commit 034a156c3f87ec5b8efa98f6f781b4959786adc2
Merge: 8573515 c5b18e2
Author: Josh Mize <jgmize@gmail.com>
Date:   Wed Jul 22 01:57:59 2015 -0500

    Merge pull request #139 from pmclanahan/fix-look-for-user-1185999

    Fix bug 1185999: Look up users in Confirmed DE properly.
[2015-08-12 15:06:39] Updating vendor.
[2015-08-12 15:06:39] Collect static assets.
[2015-08-12 15:06:41] Sync & migrate database.
/data/genericrhel6/src/basket.mozilla.org/basket/vendor/packages/django-picklefield/src/picklefield/compat.py:13: DeprecationWarning: django.utils.simplejson is deprecated; use json instead.
  from django.utils import simplejson as json
Syncing...
Creating tables ...
Installing custom SQL ...
Installing indexes ...
Installed 0 object(s) from 0 fixture(s)

Synced:
 > corsheaders
 > south
 > raven.contrib.django.raven_compat
 > django.contrib.auth
 > django.contrib.contenttypes
 > django.contrib.sessions
 > django.contrib.sites
 > django.contrib.messages
 > django.contrib.admin
 > django.contrib.staticfiles

Not synced (use migrations):
 - news
 - djcelery
(use ./manage.py migrate to migrate these)
/data/genericrhel6/src/basket.mozilla.org/basket/vendor/packages/django-picklefield/src/picklefield/compat.py:13: DeprecationWarning: django.utils.simplejson is deprecated; use json instead.
  from django.utils import simplejson as json
Running migrations for news:
- Nothing to migrate.
 - Loading initial data for news.
Installed 0 object(s) from 0 fixture(s)
Running migrations for djcelery:
- Nothing to migrate.
 - Loading initial data for djcelery.
Installed 0 object(s) from 0 fixture(s)
[2015-08-12 15:06:43] Clean up old deploy.
[2015-08-12 15:06:44] Deploying.
[2015-08-12 08:06:44] Running rsync_project
[2015-08-12 08:06:44] [localhost] running: /usr/bin/rsync -aq --include '.gitkeep' --exclude '.git*' --exclude '.hg*' --exclude '.svn*' --exclude 'CVS' --exclude '.bzr*' --delete /data/genericrhel6/src/basket.mozilla.org/ /data/genericrhel6/www/basket.mozilla.org/
[2015-08-12 08:06:45] [localhost] finished: /usr/bin/rsync -aq --include '.gitkeep' --exclude '.git*' --exclude '.hg*' --exclude '.svn*' --exclude 'CVS' --exclude '.bzr*' --delete /data/genericrhel6/src/basket.mozilla.org/ /data/genericrhel6/www/basket.mozilla.org/ (0.353s)
[2015-08-12 08:06:45] Finished rsync_project (0.353s)
[2015-08-12 08:06:45] Running commit_www
[2015-08-12 08:06:45] [localhost] running: cd /data/genericrhel6/www && /usr/bin/git add .; /usr/bin/git commit -a -m 'deploy ['basket.mozilla.org']'
[2015-08-12 08:06:49] [localhost] finished: cd /data/genericrhel6/www && /usr/bin/git add .; /usr/bin/git commit -a -m 'deploy ['basket.mozilla.org']' (4.174s)
[localhost] out: [master 0737117] deploy [basket.mozilla.org]
[localhost] out: 5 files changed, 117 insertions(+), 40 deletions(-)
[localhost] out: rewrite basket.mozilla.org/basket/static/revision_info.txt (88%)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Things seem to be working fine. Thanks again C.
Status: RESOLVED → VERIFIED
Product: Infrastructure & Operations → Infrastructure & Operations Graveyard
You need to log in before you can comment on or make changes to this bug.