Closed Bug 1193375 Opened 5 years ago Closed 5 years ago

Missing "Search" text in about:home / newtab search fields

Categories

(Firefox :: Search, defect, P3)

42 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 43
Tracking Status
firefox43 --- verified

People

(Reporter: petruta.rasa, Assigned: nhnt11)

References

Details

(Whiteboard: [fxsearch][ux bug])

Attachments

(1 file)

Reproduced with 42.0a1 (2015-08-10), all platforms.

"Search" text is missing from the search fields on about:home and about:newtab pages.

It should be shown, according to design:
http://people.mozilla.org/~shorlander/mockups/InContent-SAPs/InContent-SAPs.html
Stephen - is the mock-up old, kindof recalling the "search" was intentionally removed - the magnifying glass is the recognizable icon.
Status: NEW → UNCONFIRMED
Ever confirmed: false
Flags: needinfo?(shorlander)
Flags: firefox-backlog+
Whiteboard: [fxsearch]
(In reply to :shell escalante from comment #1)
> Stephen - is the mock-up old, kindof recalling the "search" was
> intentionally removed - the magnifying glass is the recognizable icon.

No the mockup isn't old. Should have the "Search" placeholder text. Like the Search field in the toolbar currently has.
Flags: needinfo?(shorlander)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hi Madhava - Kev vaguely remembers the "Search" text being taken out on purpose... but it's in the mock-ups still and he wants to check your memory if the magnifying glass should replace or go in addition to the "search" text.

really just memory check - OK doing either.
Flags: needinfo?(madhava)
Whiteboard: [fxsearch] → [fxsearch][ux bug]
Rank: 31
Priority: -- → P3
I think the string was just removed in bug 1190488, follow-up to bug 1171344.
(In reply to :shell escalante from comment #3)
> Hi Madhava - Kev vaguely remembers the "Search" text being taken out on
> purpose... but it's in the mock-ups still and he wants to check your memory
> if the magnifying glass should replace or go in addition to the "search"
> text.
> 
> really just memory check - OK doing either.

Not sure why it got removed in bug 1190488, but it should still be there. See comment 2.
Flags: needinfo?(madhava)
Attached patch PatchSplinter Review
Sorry for the delay in getting to this.

Nothing wrong with bug 1190488, which removed the previous about:home-specific string from the DTD.

The problem was that contentSearchUI.js never set the placeholder string received from ContentSearch.jsm (the string comes from search.properties, which is also used by the toolbar searchbar).
Assignee: nobody → nhnt11
Status: NEW → ASSIGNED
Attachment #8653740 - Flags: review?(adw)
Comment on attachment 8653740 [details] [diff] [review]
Patch

Review of attachment 8653740 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, Nihanth. :-)
Attachment #8653740 - Flags: review?(adw) → review+
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 43
Successfully reproduce this bug on Nightly 42.0a1 (2015-08-11) (Build ID: 20150811030206) with the instruction from comment 0 on Linux x64

This Bug is now verified as fixed on Latest Firefox Nightly 43.0a1 (2015-09-05)

Build ID: 20150905030205
Mozilla/5.0 (X11; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0
QA Whiteboard: [bugday-20150902]
Thanks Nazir! Marking as verified.
Status: RESOLVED → VERIFIED
Depends on: 1371860
You need to log in before you can comment on or make changes to this bug.