bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Images within table cells are improperly spaced and incorrectly stretch the table height.

VERIFIED DUPLICATE of bug 22274

Status

()

Core
Layout: Tables
--
major
VERIFIED DUPLICATE of bug 22274
17 years ago
17 years ago

People

(Reporter: Dwight Brown, Assigned: karnaze (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Images that are placed within a table cell seem to add spacing to the bottom of 
the image.

This results in a table with an image in it getting stretched to an incorrect 
size. Placing a single 22px high image into a table cell causes the table 
height to increase beyond 22px.

I put together this example, which has been W3C validate for html 4.01 strict 
and css:

http://test.invisiband.net/ver2/table.html

The tables render correctly in Opera and IE.

Comment 1

17 years ago
Yes, it's valid HTML and CSS, but Mozilla is rendering it correctly. Read bug
22274 about why and how you can fix it.

Thanks

*** This bug has been marked as a duplicate of 22274 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Yep, also see http://developer.netscape.com/evangelism/docs/articles/img-table/
for an article on how to fix this.

Verify dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.