<p> at beginning of abs positioned <div> causes extra blank line

RESOLVED DUPLICATE of bug 60535

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 60535
17 years ago
16 years ago

People

(Reporter: Stephen Moehle, Assigned: Marc Attinasi)

Tracking

({testcase})

Trunk
Future
x86
Windows 2000
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
A <p> at the beginning of an absolutely positioned <div> causes an extra blank
line before the text.

In the following example, "text 1" will appear one line below "text 2".  Both
NN4 and IE5.5 show both pieces of text on the same line.

<DIV style="position:absolute; left:2px; top:20px; width:60px"> 
<p>&quot;text 1&quot;</p>
</DIV>
<DIV style="position:absolute; left:70px; top:20px; width:60px">
&quot;text 2&quot;
</DIV>

Tested with Mozilla trunk 2002-01-10-03 on Win2000.
(Reporter)

Comment 1

17 years ago
Created attachment 64386 [details]
Simple test case.

A simple test case using the example above.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase

Comment 2

17 years ago
If you change <p> to <p style="margin:0"> then the "extra line" disappears.
IMO, the current layout is correct.
Severity: normal → minor
(Reporter)

Comment 3

17 years ago
Bull.  My testcase has a doctype that should trigger quirks mode so the page
should render as it does for NN4, IE5, IE6, and Opera.  Even in strict mode, it
should render the same way.  This attitude on the part of Mozilla that the whole
world has to kowtow to its every whim is getting tiresome.
Severity: minor → normal

Updated

17 years ago
Target Milestone: --- → Future

Comment 4

16 years ago
P has a default top and bottom margin of 1em in Mozilla.
See bug 60535 comment 8.

*** This bug has been marked as a duplicate of 60535 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.