all 60p videos in 360p when embedding only

RESOLVED FIXED

Status

()

P2
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: noiseland_27, Unassigned)

Tracking

39 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150806001005

Steps to reproduce:

I downloaded 6 videos. They are all encoded the same way . They are 1080p60 and playable everywhere on every browser but when embedded in my site , my two last videos stay at 360p even if I have a very good bandwith . 


Actual results:

Only when embedded , my last videos stays at 360p . My oldest videos are correctly embedded and all other browsers ( even Internet Explorer which is in theory the worst one ) run my videos perfectly. It's scandalous I will have to inform those who watch my site that Firefox are unable to deliver something that works normally . I can say your company will possibly cost me a job because of all it's bugs . How do you want me to explain that half of my videos are stucked in 360p ? They will think I'm a stupid guy as a video creator.... .  :(


Expected results:

The video should be embedded and play in 1080p60 like other videos (with same encoding) I previously posted on Youtube. All browsers are OK instead of Firefox and I can't tell to people to not watch my CV on Firefox. Imagine how it looks to get a job ? It would look non professionnal . I hate this browser and I'm sorry of that because I always told you were the best before this **** HTML5 integration full of bugs and the Embedded 360p professionnal videos on the quickest connexion . It's revolting. I got to give news to the welfare

Updated

3 years ago
Group: core-security

Comment 1

3 years ago
Could you provide the URL of your website or a testcase with some videos?
Flags: needinfo?(noiseland_27)

Updated

3 years ago
Component: Untriaged → Audio/Video
Product: Firefox → Core

Comment 2

3 years ago
In addition, could you test with a fresh profile: 
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Marc-André, are these embedded YouTube videos? This problem sounds like bug 1198062.
Component: Audio/Video → Audio/Video: Playback
Depends on: 1198062
Marc-André, can you still reproduce this bug? YouTube fixed bug 1198062 on their side, which probably fixed this bug.
Priority: -- → P2
(Reporter)

Comment 5

3 years ago
Pardon me for the long delay of response , I had a lot of **** things to deal with . Yes I've noticed one of my video is now embedded in 1080p60 but the other doesn't . Maybe I should re-upload. The last I uploaded is correctly embed . I'll try to re-upload this one that still doesn't work and be back to tell you the results. This Website is hosted at home so it may run a little slowly ...  but here is the link :


http://manoiseuxcv.ddns.net/CVsite/videoClips.php?id=1

Still jammed in 360p . :(
Flags: needinfo?(noiseland_27)

Comment 6

3 years ago
Indeed, 360p only offered for the embedded video, but on YT website, 720p60 and 1080p60 are available.
I believe this is a YouTube bug because I get 360p in Chrome, Safari, IE, and Edge. I will pass this information on to YouTube.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 8

3 years ago
It'S strange . In my case , the bug happens only in Firefox when embedded . I'll try to re-upload tonight
YouTube says this is a server side issue at YouTube.  Fix committed for the next YouTube push, targeted tomorrow.
(Reporter)

Comment 10

3 years ago
I don't know for you but since I re-uploaded the video, everything is fine ! So I guess the bug had to do with the uploading/encoding part on the youtube server , not the reading part on the client's side or the Firefox navigator and I think that it already has been solved by Youtube. Because there was an error in uploading/encoding , the correction can only be seen on re-uploaded videos. If all of you can watch it at 1080p60 , I guess the bug will be solved. I'm happy I seen it quickly. I wouldn't want to re-upload 10 or 16 videos .... so for those who didn't see it for weeks , I guess Youtube is still working on a solution without having to make them re-upload all the videos.
(Reporter)

Comment 11

3 years ago
I'm pretty sure the bug began as they were switching from flash to HTML5 officially. They made a lot of changes in the code .....
Thanks for testing, Marc-André. YouTube said they fixed something on their side. :)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.