[Camera] Spamming hardware camera button on video causes app to become unresponsive.

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
8 months ago

People

(Reporter: NicholasN, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [2.5-Daily-Testing][Spark], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8646593 [details]
logcat_camera.txt

Description:
The user opens the camera app and switches to video mode. While repeatedly tapping the hardware camera button or volume rocker, the time will occasionally flash/increment in the upper left corner. When the user stops pressing the button the app will be unresponsive.


Repro Steps:
1) Update a Aries to 20150811152431
2) Open the camera app.
3) Switch to video mode.
4) Repeatedly press the hardware camera button.


Actual:
App becomes unresponsive.


Expected:
App functions normally after spamming hardware camera button.


Notes:

Environmental Variables:
Device: Aries 2.5
Build ID: 20150811152431
Gaia: 9a8880a95ee4a4aea7895d4e2bcab31bc49ea281
Gecko: d82b5a78686a4f6630128fa7b999e0e343a9ef06
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0


Repro frequency: 5/5
See attached: video clip, logcat
(Reporter)

Comment 1

3 years ago
Issue also occurs on Flame 2.5, but not on Flame 2.2.

Actual Result:

App becomes unresponsive after spamming volume rocker.

Environmental Variables:
Device: Flame 2.5
BuildID: 20150811030209
Gaia: 9a8880a95ee4a4aea7895d4e2bcab31bc49ea281
Gecko: 8cba870a352c
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Flame 2.2

Actual Result:

Volume rocker does not function as a camera button on 2.2.

Environmental Variables:
Device: Flame 2.2
BuildID: 20150811032503
Gaia: 102f1299e9eafe3760e1deb44d556b5c4f36b5af
Gecko: 13c447ed929e
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Flags: needinfo?(pbylenga)
Whiteboard: [2.5-Daily-Testing][Spark]
Low use case.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
[Tracking Requested - why for this release]:
Per comment 2
tracking-b2g: --- → backlog

Comment 4

8 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.