Developer Edition theme unavailable in Release channel

RESOLVED DUPLICATE of bug 1181721

Status

()

Firefox
Theme
--
enhancement
RESOLVED DUPLICATE of bug 1181721
2 years ago
2 years ago

People

(Reporter: callahad, Unassigned)

Tracking

40 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
It's not possible to activate the DevEdition theme on Release.

Apparently a bunch of folks were using the DevEdition theme on Release by toggling browser.devedition.theme.enabled in about:config, and now that we've switched how the theme is included, that pref is ignored.

The resources still appear to be present, e.g., resource:///chrome/browser/content/browser/defaultthemes/devedition.icon.png, but we don't have a path for these folks to actually toggle the theme.

Would it be possible to add a pref or workaround for these users?

Reddit comments with folks looking for its return: https://www.reddit.com/r/firefox/comments/3gm945/is_it_possible_to_activate_devedition_theme_in/

CC'ing :bgrins since he might have context.
This has been discussed in Bug 1181721 which was WONTFIXed:

> I think we should WONTFIX this. The DevTheme is intended as a visually
> distinct theme for devtools, and that's where development focus is. If
> someone wants to spin it off into a separate heavyweight / lightweight theme
> on AMO, that's fine. (Or just use one of the existing darkish themes there)
> 
> Otherwise, this effectively becomes "add and support a dark and light theme
> to stock Firefox", and I don't think that's something we want to do given
> current priorities.

It's unfortunate that the feature was available through a pref so that we ended up removing a feature when refactoring this to work with the lightweight theme manager.  I think we should come up with some way to still support it though.. let's move the discussion to 1181721
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1181721
You need to log in before you can comment on or make changes to this bug.