[Music]It prompts "Audio cannot be played:format is unsupported or file is invalid" when listening/opening the music file in SMS/Email/Notification bar.

VERIFIED DUPLICATE of bug 1193498

Status

Firefox OS
Gaia::Music
VERIFIED DUPLICATE of bug 1193498
3 years ago
2 years ago

People

(Reporter: Shally Li(leave from Mozilla), Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [2.5-aries-test-run-1])

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
[1.Description]:
[Aries KK v2.5][Flame KK v2.5][Music]When tapping "Listen" icon to listen the music in SMS or opening the music file in Email/Notification bar,  it will prompt "Audio cannot be played:format is unsupported or file is invalid", but this music can be played in music app.

Found at: 10:20
Attach: Aries_v2.5.3gp and logcat_1020.txt
Test file: KTV_clip(1).mp3

[2.Testing Steps]: 
Precondition: Has a song (less than 295 KB) in device at least.

1. Open Messages app.
2. Create a new MMS by adding a music from Music app.
3. Tap on the attachment and tap "Listen".

[3.Expected Result]: 
3. The music attachment can be played in message app.

[4.Actual Result]: 
3. It prompts  "Audio cannot be played:format is unsupported or file is invalid" and music attachment can't be played in message.

[5.Reproduction build]: 
Device: Flame KK 2.2 (Unaffected)
Build ID               20150811032503
Gaia Revision          102f1299e9eafe3760e1deb44d556b5c4f36b5af
Gaia Date              2015-08-06 20:46:56
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/13c447ed929e
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150811.065030
Firmware Date          Tue Aug 11 06:50:39 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK 2.5 (Affected)
Build ID               20150811150203
Gaia Revision          2d7f369fd923b6df3b00d76844c413c1202c04ba
Gaia Date              2015-08-11 09:58:44
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/38c1ea9ccae31700630f1fe0d651e94c0c5b9e1d
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150811.182056
Firmware Date          Tue Aug 11 18:21:06 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5(Affected)
Build ID               20150810201912
Gaia Revision          fa89e03dc489e79baa0e74cb1d205260c7924caa
Gaia Date              2015-08-10 10:07:57
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/3f135a8ead22
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150810.194258
Firmware Date          Mon Aug 10 19:43:05 UTC 2015
Bootloader             s1


[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8.Note]:
When you download music file from email or receiving a music file by bluetooth/NFC, then open/play it, it also prompts the same message "Audio cannot be played:format is unsupported or file is invalid".
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
(Reporter)

Comment 1

3 years ago
Created attachment 8646842 [details]
logcat_1020.txt
(Reporter)

Updated

3 years ago
Keywords: regression
(Reporter)

Comment 2

3 years ago
Created attachment 8646844 [details]
Aries_v2.5.3gp
(Reporter)

Comment 3

3 years ago
Created attachment 8646863 [details]
KTV_clip(1).mp3
Appears to be a duplicate of bug 1193498, which also has a completed regression window.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1193498
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.