URLs without locale specified might result in 404

RESOLVED FIXED

Status

www.mozilla.org
Pages & Content
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: MikkCZ, Assigned: sheppy)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

We noticed issues caused by Czech (cs) available on MDN - links without
locale specified redirect to "cs" link, which results in 404 in
most cases, as there is very few content localized to Czech.

How to reproduce:
1. Go to https://www.mozilla.org/en-US/about/governance/policies/commit/ where's
a link to MDN down (https://developer.mozilla.org/Mercurial_FAQ#How_do_I_check_stuff_in.3F).
2. For Czech this link redirects to https://developer.mozilla.org/cs/Mercurial_FAQ#How_do_I_check_stuff_in.3F .
3. The page returns 404 which makes MDN unavailable for Czech developers.

Expected result:
- As there is no l10n, the link should redirect to en-US (https://developer.mozilla.org/en-US/docs/Mercurial/Using_Mercurial#How_do_I_check_stuff_in.3F).

Comment 1

2 years ago
CCing Janis, in case he's not getting bugmail anyway.

This seems to be a regression, I recall that this worked. Any ideas?
This is a bug in the source linking to MDN -- there isn't a page at that URL. We need to file a bug on the source of the link. Needinfoing myself to do that.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(hoosteeno)
Resolution: --- → INVALID
I'm sorry if there is any misunderstanding - there's no problem with the page linking to MDN, there are plenty of links without locale specified all over the Mozilla websites.

The problem is with the redirection to cs locale link, which returns 404. By changing the languages priority in Firefox you can make the universal link (without locale specified) to redirect to en-US which works well.
The link on the About page should be:

https://developer.mozilla.org/docs/Mercurial_FAQ#How_do_I_check_stuff_in.3F

Right now it is:

https://developer.mozilla.org/Mercurial_FAQ#How_do_I_check_stuff_in.3F

If you are in cs, and visit the first link, you will be redirected to en-us. 

That's the change I suggest in the source. Does it seem adequate?
Thank you, this link works fine. Would it be possible to make the second link to behave the same way, so there's no need to be afraid of such "broken" links?
(Assignee)

Comment 6

2 years ago
Moving this bug to mozilla.org site, since that's where the fix needs to go. Speaking of which, I have just submitted a PR to correct the link on mozilla.org: https://github.com/mozilla/bedrock/pull/3210
Status: RESOLVED → REOPENED
Component: General → Webdev
Product: Mozilla Developer Network → mozilla.org
Resolution: INVALID → ---
Version: unspecified → other

Updated

2 years ago
Assignee: nobody → eshepherd
Status: REOPENED → ASSIGNED
Component: Webdev → Pages & Content
Product: mozilla.org → www.mozilla.org
Version: other → Production

Comment 7

2 years ago
Commit pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/044436b2e456aa1624830c8e846a9e60c99f911e
Change mercurial usage link to fix bug 1193696

Correct the URL so that it's no longer a 404 in some locales.

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
Flags: needinfo?(hoosteeno)
You need to log in before you can comment on or make changes to this bug.