Window controls overlay the switch to tabs icons in Windows 10

RESOLVED FIXED in Thunderbird 38.0

Status

Thunderbird
Theme
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Chris, Assigned: Paenglab)

Tracking

38 Branch
Thunderbird 38.0
All
Windows 10

Thunderbird Tracking Flags

(thunderbird43 unaffected, thunderbird_esr3840+ fixed)

Details

Attachments

(4 attachments)

(Reporter)

Description

2 years ago
Created attachment 8646895 [details]
Capture for Desktop.jpg

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150807085045

Steps to reproduce:

Open Thunderbird in full screen mode.


Actual results:

The Window controls (top right) partially overlap the Switch to tab controls.

The problem exist on my laptop with the screen resolution of 3200x1800, but not on my desktop PC with screen resolution of 1920x1080


Expected results:

There should be separation between these two areas as show in "Capture for Desktop.jpg". See next entry for problem jpg.
(Reporter)

Comment 1

2 years ago
Created attachment 8646896 [details]
Capture on Laptop.JPG

Here is the jpg of the problem on the laptop.
(Assignee)

Comment 2

2 years ago
This is like bug 1179283 for FX when the screen is scaled. Then the caption button width is not correctly calculated. This is fixed for 40+ and will not be fixed on ESR.
Status: UNCONFIRMED → NEW
Component: Untriaged → Theme
Ever confirmed: true
OS: Unspecified → Windows 10
Hardware: Unspecified → All
(Assignee)

Comment 3

2 years ago
Created attachment 8646926 [details] [diff] [review]
1193721.patch

Kent, I'm asking you for review as it is a TB 38 only issue and you are building ESR and have also a win 10 machine for testing. I don't build ESR and have it only with DOMi tested but it works.

Added the ESR approval flags because it's only a TB 38 issue and needs to land on ESR only.

[Approval Request Comment]
Regression caused by (bug #): Windows 10
User impact if declined: some buttons almost unusable on scaled screens
Testing completed (on c-c, etc.): 
Risk to taking this patch (and alternatives if risky): Low, it's only CSS
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8646926 - Flags: review?(rkent)
Attachment #8646926 - Flags: approval-comm-esr38?

Updated

2 years ago
See Also: → bug 1180212

Comment 4

2 years ago
Comment on attachment 8646926 [details] [diff] [review]
1193721.patch

Review of attachment 8646926 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM, and I can see the width-143 in DOM Inspector
Attachment #8646926 - Flags: review?(rkent) → review+

Updated

2 years ago
status-thunderbird43: --- → unaffected
status-thunderbird_esr38: --- → affected
tracking-thunderbird_esr38: --- → 40+
Target Milestone: --- → Thunderbird 38.0

Comment 5

2 years ago
Comment on attachment 8646926 [details] [diff] [review]
1193721.patch

http://hg.mozilla.org/releases/comm-esr38/rev/03ff3b80815f

This patch will not land except in comm-esr38
Attachment #8646926 - Flags: approval-comm-esr38? → approval-comm-esr38+

Updated

2 years ago
status-thunderbird_esr38: affected → fixed
(Reporter)

Comment 6

2 years ago
Created attachment 8662917 [details]
Sample from 41.0b2

The problem is even worse with 41.0b2, as none of the 3 window control are functional, and cannot be selected. In the attachment the cursor is actually completely covering the twistie. Nothing happens if the cursor is over the Window X control.
(Assignee)

Comment 7

2 years ago
Chris, are you using a third party theme? The icons of standard theme aren't colored. It seems your theme isn't Win10 ready. With default theme you should see the caption buttons like in bug 1205637.
Flags: needinfo?(4myforums)
(Reporter)

Comment 8

2 years ago
Good catch. Yes, I was using "Noia Fox". Reverted to the Default and it is fine.
Flags: needinfo?(4myforums)
(Assignee)

Comment 9

2 years ago
Thank you for the info.

I'll close this bug as the patch has landed.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.