The loading Firefox OS image is on top of other apps after some operations

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: julienw, Unassigned)

Tracking

({foxfood})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8646897 [details]
screenshot

After some operations I got the issue of the loading image was on top of everything. Yet the phone was still "working" (I could display the utility tray, the lockscreen was working, the task manager was working) but I could display no application because the loading image always stays on top of all apps.

My STR was that I opened some links in another window from a pinned website (in my case: http://lemonde.fr). I did that several times on the same build without having the issue, so there is likely a race.

See attached screenshot + logs.
(Reporter)

Comment 1

3 years ago
Created attachment 8646900 [details]
logcat

I think the issue happened around 09:31 in this log. But I don't see much useful things, except maybe an error in system/js/costcontrol.js.
(Reporter)

Updated

3 years ago
Attachment #8646900 - Attachment mime type: text/x-log → text/plain
Keywords: steps-wanted
(Reporter)

Comment 2

3 years ago
For QA to find out, there are definitely weird things happening when I open a link in a new window _and_ I start an edge gesture while or just before the new window opens.

For example this time I got the new window and edge gesture were not working yet I saw the status bar doing things -- Etienne thinks the edge gesture was working behind the window.

Yet I could kill that window this time (I couldn't with the loading image issue).
I was not able to reproduce this issue on Aries or Flame. I went to a website (lemonde.fr), long-tapped on a link and selected 'Open in new window', while it was opening a window I quickly edge gestured back and forth. At no point did I see a window appearing above all other windows. I tried with today's build as well as a build on 8/12 (time when this bug was written) and could not reproduce.

Reproduction rate: 0 out of ~100.

No repro on:
Device: Aries 2.5
BuildID: 20150812231434
Gaia: 52f3ea58df38e5427f6afeb636bc6ad01d24022f
Gecko: 7649ffe28b67aa2dad0f67ea01500c0ff91b2bac
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Device: Flame 2.5
BuildID: 20150908030224
Gaia: 891798f1e345bc2b69e71de42bd524a90b1745c4
Gecko: 5fe9ed3edd6811a662d40d05e37b0d66e9520d82
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Device: Aries 2.5
BuildID: 20150908152248
Gaia: b81185d30e548f782770b852473ffb53c641a490
Gecko: b23b2fa33a9dcda59dbbca1d157eca3c32c5b862
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
Flags: needinfo?(jmercado)
Flags: needinfo?(jmercado)
(Reporter)

Comment 4

2 years ago
I agree I don't see exactly the same bug with my current foxfooding build (BuildID: 20150812225219). 

I still got a weird behavior with this STR:

0. Prerequisite: you need to be able to do an edge gesture from the right (have a window on the "right" side).
1. open a link in a new window.
2. quickly start a edge gesture to the _right_ while this is happening.
3. then try to edge gesture to the right.
=> You'll see one of the windows on the "bottom" behind the one being swiped.

This is definitely not as serious as the original bug.
See Also: → bug 1221230
I was not able to reproduce this issue on Flame 2.5 using the STR's in comment 1,3 or adhoc. The FireFox OS loading image did not appear using these steps. 

Reproduction rate: 0 out of ~25.

No Repro on: 
Environmental Variables:
Device: Aries 2.5
BuildID: 20151130171620
Gaia: 391bcad1b3b427f189f4c7f11858fc739574682e
Gecko: 1a022b4b67446b50f36c098aa425c65782af9066
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 44.0a2 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0


Environmental Variables:
Device: Flame 2.5
BuildID: 20151201163815
Gaia: 07462becf08f0c26ebd64daf89646e7403a336c5
Gecko: 33a575e711faf3344aa2e31ca2ea066b4cd8aafa
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a2 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
I was also unable to reproduce this issue on an Aries build from today for master or 2.5.  

Julien are you still seeing this issue?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(felash)
Keywords: steps-wanted
(Reporter)

Comment 7

2 years ago
No I don't think I saw the issue lately.
Flags: needinfo?(felash)
(Reporter)

Comment 8

2 years ago
I'll reopen if I see this again.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.