Hitting cancel button in print dialog from Messenger results in crash

VERIFIED DUPLICATE of bug 118017

Status

VERIFIED DUPLICATE of bug 118017
17 years ago
11 years ago

People

(Reporter: grylchan, Assigned: rods)

Tracking

({crash})

Trunk
x86
Windows NT
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Using commercial 2002-01-10-12-trunk build on win nt 4.0

If I try to print mail message using (print icon or file menu)
and the print dialog window pops up, if I hit the cancel button
it will result in mozilla crashing. Does not crash if you hit
the print button. 

It does not crash if I try to print from the
browser or composer and hit the cancel button in the print dialog window.
Crashes only in messenger

Steps to reproduce:
1.Login to your imap mail acct.
2.Select a mesg or double click and bring it up in seperate window
3.Click the print icon or File|Print
4.The print dialog appears
5.Click cancel button

result: application crashes
expected: print dialog window to dismiss and the application to still
          be running.

I've enclosed stack trace and talk back ids.

TB1506604W, TB1506348E, TB1506170Y

nsBoxFrameInner::Recycle 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 2153] 
nsBoxFrame::Destroy 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 1178] 
nsFrameList::DestroyFrames 
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 131] 
nsContainerFrame::Destroy 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
140] 
ViewportFrame::Destroy 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsViewportFrame.cpp, line 157] 
FrameManager::Destroy 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 517] 
PresShell::Destroy 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 1724] 
DocumentViewerImpl::Destroy 
[d:\builds\seamonkey\mozilla\content\base\src\nsDocumentViewer.cpp, line 1392] 
nsDocShell::Destroy [d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, 
line 2534] 
nsWebShell::Destroy [d:\builds\seamonkey\mozilla\docshell\base\nsWebShell.cpp, 
line 1218] 
nsXULWindow::Destroy 
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsXULWindow.cpp, line 372] 
nsWebShellWindow::Destroy 
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsWebShellWindow.cpp, line 1761] 
nsChromeTreeOwner::Destroy 
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsChromeTreeOwner.cpp, line 227] 
GlobalWindowImpl::ReallyCloseWindow 
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 2560] 
GlobalWindowImpl::Close 
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 2548] 
nsMsgPrintEngine::StartNextPrintOperation 
[d:\builds\seamonkey\mozilla\mailnews\base\src\nsMsgPrintEngine.cpp, line 282] 
nsMsgPrintEngine::OnStateChange 
[d:\builds\seamonkey\mozilla\mailnews\base\src\nsMsgPrintEngine.cpp, line 160] 
PrintData::DoOnProgressChange 
[d:\builds\seamonkey\mozilla\content\base\src\nsDocumentViewer.cpp, line 849] 
PrintData::OnEndPrinting 
[d:\builds\seamonkey\mozilla\content\base\src\nsDocumentViewer.cpp, line 829] 
DocumentViewerImpl::Destroy 
[d:\builds\seamonkey\mozilla\content\base\src\nsDocumentViewer.cpp, line 1362] 
nsDocShell::Destroy [d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, 
line 2534] 
nsWebShell::Destroy [d:\builds\seamonkey\mozilla\docshell\base\nsWebShell.cpp, 
line 1218] 
nsHTMLFrameInnerFrame::~nsHTMLFrameInnerFrame 
[d:\builds\seamonkey\mozilla\layout\html\document\src\nsFrameFrame.cpp, line 
668] 
nsHTMLFrameInnerFrame::`scalar deleting destructor' 
nsFrame::Destroy [d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrame.cpp, 
line 472] 
nsFrameList::DestroyFrames 
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 131] 
nsContainerFrame::Destroy 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
140] 
nsFrameList::DestroyFrames 
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 131] 
nsContainerFrame::Destroy 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
140] 
nsBoxFrame::Destroy 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 1181] 
nsFrameList::DestroyFrames 
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 131] 
nsContainerFrame::Destroy 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
140] 
nsBoxFrame::Destroy 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 1181] 
nsFrameList::DestroyFrames 
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 131] 
nsContainerFrame::Destroy 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
140] 
ViewportFrame::Destroy 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsViewportFrame.cpp, line 157] 
FrameManager::Destroy 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 517] 
PresShell::Destroy 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 1724] 
DocumentViewerImpl::Destroy 
[d:\builds\seamonkey\mozilla\content\base\src\nsDocumentViewer.cpp, line 1392] 
nsDocShell::Destroy [d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, 
line 2534] 
nsWebShell::Destroy [d:\builds\seamonkey\mozilla\docshell\base\nsWebShell.cpp, 
line 1218] 
nsXULWindow::Destroy 
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsXULWindow.cpp, line 372] 
nsWebShellWindow::Destroy 
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsWebShellWindow.cpp, line 1761] 
nsChromeTreeOwner::Destroy 
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsChromeTreeOwner.cpp, line 227] 
GlobalWindowImpl::ReallyCloseWindow 
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 2560] 
GlobalWindowImpl::Close 
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 2548] 
nsMsgPrintEngine::StartNextPrintOperation 
[d:\builds\seamonkey\mozilla\mailnews\base\src\nsMsgPrintEngine.cpp, line 282] 
nsMsgPrintEngine::OnStateChange 
[d:\builds\seamonkey\mozilla\mailnews\base\src\nsMsgPrintEngine.cpp, line 130] 
nsDocLoaderImpl::FireOnStateChange 
[d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp, line 1110] 
nsDocLoaderImpl::doStopDocumentLoad 
[d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp, line 749] 
nsDocLoaderImpl::DocLoaderIsEmpty 
[d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp, line 647] 
nsDocLoaderImpl::OnStopRequest 
[d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp, line 578] 
nsLoadGroup::RemoveRequest 
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsLoadGroup.cpp, line 530] 
nsLoadGroup::Cancel 
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsLoadGroup.cpp, line 248] 
nsDocLoaderImpl::Stop 
[d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp, line 296] 
nsDocLoaderImpl::Stop 
[d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp, line 289] 
nsURILoader::Stop [d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, 
line 551] 
nsDocShell::Stop [d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, line 
2368] 
nsDocShell::Destroy [d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, 
line 2515] 
nsWebShell::Destroy [d:\builds\seamonkey\mozilla\docshell\base\nsWebShell.cpp, 
line 1218] 
nsXULWindow::Destroy 
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsXULWindow.cpp, line 372] 
nsWebShellWindow::Destroy 
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsWebShellWindow.cpp, line 1761] 
nsChromeTreeOwner::Destroy 
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsChromeTreeOwner.cpp, line 227] 
GlobalWindowImpl::ReallyCloseWindow 
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 2560]
(Reporter)

Comment 1

17 years ago
adding keyword crash
Keywords: crash
(Reporter)

Comment 2

17 years ago
Not sure if this is a dupe of bug 64594 

Comment 3

17 years ago
over to rods
Assignee: dcone → rods
(Assignee)

Comment 4

17 years ago

*** This bug has been marked as a duplicate of 118017 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
verified dup.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.