If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Intermittent OSX 10.10 command timed out: 3600 seconds without output running ['/tools/buildbot/bin/python', 'scripts/scripts/talos_script.py', '--suite', 'dromaeojs', '--add-option', '--webServer,localhost', '--branch-name', 'Firefox', '--system-bits', '

RESOLVED FIXED

Status

Testing
Talos
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: RyanVM, Assigned: kmoir)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Working on bisecting this now. Not sure if this is from a code change or infra yet.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 14

2 years ago
These are all happening on the newly-reimaged rev5s. Any ideas what might be going on, Kim?
Flags: needinfo?(kmoir)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 16

2 years ago
I'm investigating
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 48

2 years ago
I'm still investigating but haven't found a cause yet.  It's strange that this is limited to machines 104 through 107 when the new machines are  t-yosemite-r5-0096 - 0107.  I do notice however that these machiens are in rack 401-7 - scl3 - 11.10 while the other ones are in 401-7 - scl3 - 11.10
Flags: needinfo?(kmoir)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 59

2 years ago
The problem is that these machines lack content in /builds/slave/talos-data/talos
and thus some of the tests that require this info timeout because the local webserver cannot serve it during the talos tests.  The other machines do contain it.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 65

2 years ago
Okay found the source of the problem.  I have a script to generate slavealloc entries that I used the last time I added yosemite slaves.  Since then, the basedir for yosemite changed from /builds/slave/talos-slave to /builds/slave. When I added the new machines this week, they had the wrong basedir.  So the machines were unpacking the talos files into the wrong dir as referenced in talos.conf.  So the apache server was not able to server the content required by the tests.  I've fixed that and they subsequent tests that start should not have this problem.  I've also updated my script.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 68

2 years ago
I can see that these machines all ran these talos tests successfully so closing the bug.
Assignee: nobody → kmoir
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.