[Dialer] Hold/pause button is enabled automatically when answering call.

VERIFIED FIXED in Firefox OS master

Status

VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: NicholasN, Assigned: alwu)

Tracking

({regression, smoketest})

unspecified
FxOS-S5 (21Aug)
ARM
Gonk (Firefox OS)
regression, smoketest
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master fixed)

Details

(Whiteboard: [2.5-Daily-Testing][Spark][dogfood-blocker], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8647019 [details]
logcat_call.txt

Description:
When the user receives a call and taps the answer button, hold will be enabled automatically. The user must disable it before conducting their call.


Repro Steps:
1) Update an Aries to 20150812135535
2) Go to the homescreen and have a another phone call the device.
3) Tap the accept call button.


Actual:
The receiving phone enters the call with hold enabled.


Expected:
Hold is not enabled automatically.


Notes:

Environmental Variables:
Device: Aries 2.5
Build ID: 20150812135535
Gaia: 6fef72357971934c8774578044ea7a442be3a75d
Gecko: b7efed3a2640fba681d48846c3b2ab80474c6f77
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0


Repro frequency: 5/5
Link to failed test case: https://moztrap.mozilla.org/manage/case/1300/
See attached: video clip, logcat
(Reporter)

Comment 1

3 years ago
Issue also occurs Flame 2.5 but not Flame 2.2.

Flame 2.5

Actual Result:

Hold is enabled when answering call.

Environmental Variables:
Device: Flame 2.5
BuildID: 20150812073105
Gaia: 6fef72357971934c8774578044ea7a442be3a75d
Gecko: 8584e1ea8f6ac747d828cc2604cfc34a680ff95b
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Flame 2.2

Actual Result:

Answering call does not automatically enable hold.

Environmental Variables:
Device: Flame 2.2
BuildID: 20150811123013
Gaia: 102f1299e9eafe3760e1deb44d556b5c4f36b5af
Gecko: 9295034c0ee3
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Flags: needinfo?(pbylenga)
Keywords: regression, smoketest
Whiteboard: [2.5-Daily-Testing][Spark]
[Blocking Requested - why for this release]:
Severe functional regression failing smoke tests.

Requesting a window to identify the commit to backout.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: qaurgent, regressionwindow-wanted
QA Contact: pcheng
Should block OTA for dogfooders.
Whiteboard: [2.5-Daily-Testing][Spark] → [2.5-Daily-Testing][Spark][dogfood-blocker]
b2g-inbound regression window:

Last Working
Device: Flame
BuildID: 20150811075840
Gaia: 2052b591db7af90341012ea780bcca3f54d100e0
Gecko: da4dab7c34e99177633b399f7294c17d953aae14
Version: 43.0a1 (2.5 Master) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

First Broken
Device: Flame
BuildID: 20150811081935
Gaia: 2052b591db7af90341012ea780bcca3f54d100e0
Gecko: 863a1606a3a829891f73dcdcc0789b0b568c99a0
Version: 43.0a1 (2.5 Master) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Gaia is the same so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=da4dab7c34e99177633b399f7294c17d953aae14&tochange=863a1606a3a829891f73dcdcc0789b0b568c99a0

Caused by changes made in Bug 1129882.
Blocks: 1129882
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qaurgent, regressionwindow-wanted
Alastor, can you take a look at this please? This looks to have been caused by the landing for bug 1129882.
Flags: needinfo?(ktucker) → needinfo?(alwu)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
(Assignee)

Comment 6

3 years ago
This bug is caused by the hack in audio_competing_helper.js.
The bug1185442 would remove them.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(alwu)
Resolution: --- → DUPLICATE
Duplicate of bug: 1185442
Bug 1185442 won't be implemented until the people of Dialer are back. That is to say, at least, next week.

The regression mentioned here, is breaking the smoke tests. Compared to the build of the day before, I also noticed that you can't change the touchtones volume on the keypad anymore. We can't ship a new fogfood OTA update on friday if these issues are still here.

In order to get the dialer working again, I would suggest to turn off bug 1129882, wait for the gaia patch to be ready, and then, land both of them.
Flags: needinfo?(alwu)
Comms triage: Agree with comment 7. Please coordinate the back out and the Gaia land.
Status: RESOLVED → REOPENED
blocking-b2g: 2.5? → 2.5+
Resolution: DUPLICATE → ---
This issue has been resolved fix on master for aries devices due to the backout performed in bug 1129882
Results: Call is not placed on hold upon answering

* http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=03d70e0295d4&tochange=7649ffe28b67aa2dad0f67ea01500c0ff91b2bac
** changelog from the backout commit to dogfood-latest gecko commit not experiencing issue

Device: Aries Master
BuildID: 20150812231434
Gaia: 52f3ea58df38e5427f6afeb636bc6ad01d24022f
Gecko: 7649ffe28b67aa2dad0f67ea01500c0ff91b2bac
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (Master) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
Repro: 10/10 passing
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Assignee: nobody → alwu
status-b2g-master: affected → fixed
Target Milestone: --- → FxOS-S5 (21Aug)
(Assignee)

Updated

3 years ago
Flags: needinfo?(alwu)
Moving the bug to the component where the regression came from.
Component: Gaia::Dialer → AudioChannel
You need to log in before you can comment on or make changes to this bug.