Closed Bug 119389 Opened 19 years ago Closed 1 year ago

display= doesn't work if extends= is not present

Categories

(Core :: XBL, defect)

defect
Not set
normal

Tracking

()

RESOLVED WONTFIX
Future

People

(Reporter: bryner, Unassigned)

Details

(Whiteboard: INVALIDATEME)

Attachments

(1 file)

If you use display= on a binding without also using extends=, display= does not
work, i.e.

<binding id="foo" display="xul:outliner"/>
Status: NEW → ASSIGNED
Target Milestone: --- → Future
I've a patch for this
Attached patch patch v1Splinter Review
this patch just adds a !hasDisplay to the logic so that it doesn't skip in the
case when hasDisplay is true but hasExtends is false.
My understanding was that this was by design.

Use <binding id="foo" extends="xul:button"> if you don't inherit

Use <binding id="foo" display="xul:button" extends="..."> if you do.
Whiteboard: INVALIDATEME
well in that case can we change the design? Note that even with this patch
<binding id="foo" extends="xul:button"> would still work.
So, is this a valid bug, or not?
Personally, I would like <binding id="foo" display="xul:outliner"/> to work.
QA Contact: jrgmorrison → xbl
Assignee: hyatt → nobody
This is a mass change. Every comment has "assigned-to-new" in it.

I didn't look through the bugs, so I'm sorry if I change a bug which shouldn't be changed. But I guess these bugs are just bugs that were once assigned and people forgot to change the Status back when unassigning.
Status: ASSIGNED → NEW

XBL is now disabled in Firefox (Bug 1583314) and is in the process of being removed from Gecko (Bug 1566221), so closing bugs requesting changes to its implementation as wontfix.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.