check for updates : nothing happens

RESOLVED FIXED

Status

P2
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: nwinter, Assigned: daleharvey)

Tracking

({foxfood})

unspecified
foxfood

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 wontfix, b2g-master affected)

Details

(Whiteboard: [bzlite][systemsfe])

Attachments

(5 attachments)

(Reporter)

Description

3 years ago
User-Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

I was surprised my device never received an updated so went into settings and clicked on "check now". Although the status bar showed some data exchange activity, nothing happened. No notification whether an update has been found or not or to tell me that my device is already running the latest available version...
(Reporter)

Comment 1

3 years ago
Created attachment 8647107 [details]
2015-08-12-21-24-19.png
Can you please confirm if this is desired behaviour?
Flags: needinfo?(firefoxos-ux-bugzilla)
I believe the UX could be better here, more clear. Harly do we have a spec already for this?
Thanks!
Flags: needinfo?(hhsu)
QA Whiteboard: [foxfood-triage]
(Reporter)

Comment 4

3 years ago
My desired behaviour would be to get a notification after pressing "check now" : either "your devices is up to date" or "there's a new version available"

Comment 5

3 years ago
Created attachment 8650841 [details]
[Settings] OTA v1.11.pdf

Here is the newest slide done previously by Jenny. Hope this helps :)
Flags: needinfo?(hhsu)
This is awesome Harly! Thanks. Reviewing the designs, it doesn't look like the behaviour Natalia is seeing is to spec. Can we get QA to verify? 

Thanks! And thanks for pinging the UX team!!
Flags: needinfo?(firefoxos-ux-bugzilla)
Keywords: qawanted

Comment 7

3 years ago
Created attachment 8652296 [details]
logcat_2249_Flame KK2.5.txt

This bug can't be repro on Aries KK v2.5, but can be repro on Flame KK v2.2 & v2.5 by the STR in comment0.

Actual results: 
(1)On Flame KK v2.2, on secondary build (20150823032504), there is a notification for update after clicked on "check now"(rate: 0/3). On latest build(20150824032503), there is 

no suggestion/prompt message after clicked on "check now"(rate: 3/3).

(2)On Flame KK v2.5, there is no suggestion/prompt message after clicked on "check now"(rate: 3/3).

(3)On Aries KK v2.5, when update channel is dogfood-latest or nightly,there is a suggestion/prompt message after clicked on "check now" first time(rate: 0/3).

See attachments: Flame & Aries.png and logcat_2249_Flame KK2.5.txt.


----------------------------------------------------------------------------------------------
Device: Flame KK 2.2 build(Affected)
Build ID               20150823032504
Gaia Revision          335cd8e79c20f8d8e93a6efc9b97cc0ec17b5a46
Gaia Date              2015-08-14 19:06:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/1effc4cb6414
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150823.070624
Firmware Date          Sun Aug 23 07:06:34 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK 2.2 build (Affected)
Build ID               20150824032503
Gaia Revision          335cd8e79c20f8d8e93a6efc9b97cc0ec17b5a46
Gaia Date              2015-08-14 19:06:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/1effc4cb6414
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150824.065506
Firmware Date          Mon Aug 24 06:55:15 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK 2.5 build(Affected)
Build ID               20150823150207
Gaia Revision          cddb9f610cbe03d0ca39d81bbdce46a0fca841ab
Gaia Date              2015-08-23 03:34:38
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/4ccdd06e51d7209ba429196df7cab97bf66962db
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150823.184457
Firmware Date          Sun Aug 23 18:45:09 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK 2.5 build (Affected)
Build ID               20150824150208
Gaia Revision          d7fb5717d3e0153ac64af2c0d5c11079846d81c3
Gaia Date              2015-08-24 10:07:41
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ba43a48d3c528cc956335793e02504e5ca2c149f
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150824.182021
Firmware Date          Mon Aug 24 18:20:30 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

--------------------------------------------------------------------------------------------
Device: Aries KK 2.5 build (Unaffected, dogfood-latest and nightly)
Build ID               20150825010113
Gaia Revision          b441bde54293bea5254dc340845effe951fa3906
Gaia Date              2015-08-24 17:47:19
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/ef0614cdd437fadc77d7140bbc7d377a4121834a
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150825.004753
Firmware Date          Tue Aug 25 00:48:02 UTC 2015
Bootloader             s1

Device: Aries KK 2.5 build(Unaffected, dogfood-latest and nightly)
Build ID               20150823222121
Gaia Revision          cddb9f610cbe03d0ca39d81bbdce46a0fca841ab
Gaia Date              2015-08-23 03:34:38
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/4ccdd06e51d7209ba429196df7cab97bf66962db
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150823.214449
Firmware Date          Sun Aug 23 21:44:57 UTC 2015
Bootloader             s1

Comment 8

3 years ago
Created attachment 8652298 [details]
Flame&Aries.png

Updated

3 years ago
QA Whiteboard: [foxfood-triage] → [foxfood-triage], [MGSEI-Triage+]
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Keywords: qawanted
I also ran into another issue today. I had a notification for a new update, but forgot it was there. I went to check for updates and nothing happened. We should let the user know an update is waiting instead of providing no feedback.

NI - I'm not sure who would fix this...
Flags: needinfo?(mpotharaju)
Michael, Can you please provide some info or reassign this?

Thanks
Flags: needinfo?(mpotharaju) → needinfo?(mhenretty)
Looks like our dogfood builds on Aries are unaffected, which means we won't drop everything to fix it. Still this needs to block 2.5.

(In reply to Tiffanie Shakespeare [:tif] UX from comment #9)
> I also ran into another issue today. I had a notification for a new update,
> but forgot it was there. I went to check for updates and nothing happened.
> We should let the user know an update is waiting instead of providing no
> feedback.
> 
> NI - I'm not sure who would fix this...

Can you file a new bug for this? We may still fix in 2.5, but we should triage that separately.
blocking-b2g: --- → 2.5+
status-b2g-v2.2: affected → wontfix
Component: Gaia::Feedback → Gaia::System
Flags: needinfo?(mhenretty) → needinfo?(tshakespeare)
Whiteboard: [bzlite] → [bzlite][systemsfe]
Is this a dup of bug 1186332?
Done - Bug 1201218

Thanks!
Flags: needinfo?(tshakespeare)
(In reply to Gregor Wagner [:gwagner] from comment #12)
> Is this a dup of bug 1186332?

Looks very similar, but the strange thing is that one is for Aries device, and this one only for Flame. This comment [1] seems to say the behavior is device dependent, so let's keep both open and separate for now.

1.) https://bugzilla.mozilla.org/show_bug.cgi?id=1186332#c29
Assignee: nobody → dale
(Assignee)

Comment 15

3 years ago
I do not have an aries available for dev at the moment, I dropped my dogfood device and broke its screen so now my dev aries is my only phone. Jean is shipping me a new device and fedex said it should be here by tuesday so I will pick this bug up when I get the device if it isnt closed by then (or closed by the flame issue), but deassigning myself in case someone can pick it up before that.
Assignee: dale → nobody
(Assignee)

Comment 16

3 years ago
I wait, this one is the flame one, will work on this one now
Assignee: nobody → dale
I wonder how much of there reports would be fixed by skipping this timeout [1] for system updates.

We had it since 1.0 and it was originally intended to prevent showing a banner N times when N apps had an update (we get notified by gecko once for each app, not in batch).

But there can only be one system update at a time :)

[1] https://github.com/mozilla-b2g/gaia/blob/badac959a9ce25f7c168b09842341f4d7a7b5ba8/apps/system/js/update_manager.js#L31
(Reporter)

Comment 18

3 years ago
I tried again with latest OTA I received on my Aries (build identifier : 20151002103912), still same behaviour, after clicking "check now" nothing happens...
(Assignee)

Comment 19

3 years ago
It seems like not having a timeout and being able to update that notification would be the ideal improvement for that, get a notification as soon as an update comes in.

But regardless of the notifications the settings app just straight up hides the UI when its finished checking for an update, nothing in there to ensure its visible for any period of time - https://github.com/mozilla-b2g/gaia/blob/badac959a9ce25f7c168b09842341f4d7a7b5ba8/apps/settings/js/panels/about/update_check.js#L85 should be a straightforward fix
Created attachment 8675646 [details] [review]
[gaia] daleharvey:1193910 > mozilla-b2g:master
(Assignee)

Comment 21

3 years ago
Comment on attachment 8675646 [details] [review]
[gaia] daleharvey:1193910 > mozilla-b2g:master

The current code for this hides the status when the check was complete which could be instantaneous, this ensures the last message is shown for 5 seconds.
Attachment #8675646 - Flags: review?(gasolin)
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1186332

Comment 23

3 years ago
Comment on attachment 8675646 [details] [review]
[gaia] daleharvey:1193910 > mozilla-b2g:master

For quick glance I found the _checkStatus[setting] status is missing, so the patch can't garentee it actually get all update status then hide after 5s
Attachment #8675646 - Flags: review?(gasolin)
Priority: -- → P2
(Assignee)

Comment 24

3 years ago
Comment on attachment 8675646 [details] [review]
[gaia] daleharvey:1193910 > mozilla-b2g:master

Restored the hasAllUpdateComplete check so it will only start hiding once they are all finished
Attachment #8675646 - Flags: review?(gasolin)

Comment 25

3 years ago
Comment on attachment 8675646 [details] [review]
[gaia] daleharvey:1193910 > mozilla-b2g:master

Looks good, thanks Dale!
Attachment #8675646 - Flags: review?(gasolin) → review+
(Assignee)

Comment 26

3 years ago
Sweet thanks, test run was green, merged in https://github.com/mozilla-b2g/gaia/commit/1b902ff26547e2a6c896351a6a73b673f65e19b2
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Updated

3 years ago
Duplicate of this bug: 1187550
You need to log in before you can comment on or make changes to this bug.