Disable setting store type due to maildir issues

RESOLVED FIXED in Thunderbird 38.0

Status

Thunderbird
Preferences
RESOLVED FIXED
2 years ago
9 months ago

People

(Reporter: rkent, Assigned: rkent)

Tracking

(Blocks: 1 bug)

Trunk
Thunderbird 38.0
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird_esr3840+ fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
Various issues in Thunderbird 38 with maildir mean we really don't want casual users selecting it, so disable options to change store type.
(Assignee)

Comment 1

2 years ago
Created attachment 8647148 [details] [diff] [review]
Disable store type changes

This will only land in esr-38, we'll leave enabled in trunk.
Assignee: nobody → rkent
Status: NEW → ASSIGNED
Attachment #8647148 - Flags: review?(mkmelin+mozilla)
(Assignee)

Updated

2 years ago
Blocks: 1175242, 1152651
(Assignee)

Comment 2

2 years ago
Comment on attachment 8647148 [details] [diff] [review]
Disable store type changes

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Testing completed (on c-c, etc.): 
Risk to taking this patch (and alternatives if risky):
Attachment #8647148 - Flags: approval-comm-esr38?
(Assignee)

Updated

2 years ago
tracking-thunderbird_esr38: --- → 40+

Comment 3

2 years ago
Comment on attachment 8647148 [details] [diff] [review]
Disable store type changes

Review of attachment 8647148 [details] [diff] [review]:
-----------------------------------------------------------------

We should make sure to update https://support.mozilla.org/kb/maildir-thunderbird too
Attachment #8647148 - Flags: review?(mkmelin+mozilla) → review+
Does this mean that maildir will be disabled in official releases for some indefinite period of time?

I have been using maildir since the beginning of April 2015.

Switched to maildir to simplify by backup procedures.

Alex
(Assignee)

Comment 5

2 years ago
(In reply to mcmurchy1917-bugzilla from comment #4)
> Does this mean that maildir will be disabled in official releases for some
> indefinite period of time?
> 
> I have been using maildir since the beginning of April 2015.
> 
> Switched to maildir to simplify by backup procedures.
> 
> Alex

No, what it means is that the user interface to make it easier to select maildir is being disabled. You can still set the default store manually using the config editor, and any existing accounts using maildir will have no change in their operation.

I'm hoping this will only be for a minor release or two until we solve a couple of issues.
(Assignee)

Comment 6

2 years ago
Comment on attachment 8647148 [details] [diff] [review]
Disable store type changes

https://hg.mozilla.org/releases/comm-esr38/rev/045312fc9aa0
Attachment #8647148 - Flags: approval-comm-esr38? → approval-comm-esr38+
(Assignee)

Updated

2 years ago
status-thunderbird_esr38: --- → fixed
Duplicate of this bug: 1199636
(Assignee)

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 38.0
Blocks: 1306254
You need to log in before you can comment on or make changes to this bug.