Mozilla leaves shadows of menus when moving back and forth

RESOLVED WORKSFORME

Status

()

Core
XUL
--
minor
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Krishnakumar B, Assigned: David Hyatt)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7+) Gecko/20020110
BuildID:    2002011015

When I right click in a page and hit back on the popup menu, Mozilla renders a
transient gray box which is same in width & height as the popup menu before
displaying the previous page. The same thing happens when you click forward from
the popup menu.

Reproducible: Always
Steps to Reproduce:
1.Open a couple of pages. 
2.Right click on a page and click back or any of the other options.
3. 

Actual Results:  Mozilla leaves a ghost representing the popup menu's height and
width. The box is transient but long enough to notice without any straining.

Expected Results:  No ghost images should be present.

I checked with Mozilla 0.9.7 and it works fine. This shows up from day before
yesterday, IIRC. I am using Linux (RedHat 7.2) and XFree86 4.1.0 . I guess I am
clean on the driver/kernel/display side as it doesn't occur with Mozilla 0.9.7.

Comment 1

16 years ago
->morse
Assignee: trudelle → morse
wouldn't this be toolkit? punt as needed...
Assignee: morse → hyatt
Component: XP Apps → XP Toolkit/Widgets: Menus
QA Contact: sairuh → jrgm

Comment 3

16 years ago
Reporter,

Can you reproduce this in release 0.9.9 or a nightly?

Comment 4

16 years ago
I have had this problem before, but now when I right-click and select Back, the
pop-up menu doesn't disappear as it should -- it stays on the screen (although
the entire application is unresponsive) until it "unfreezes" and renders the
previous page.

Suggestion: begin executing the 'back' code (or whatever Mozilla does) only
after redrawing the screen to remove the menu.

Changed severity from normal to minor, although this is trivial enough to
warrant... trivial level. :)
Severity: normal → minor

Comment 5

16 years ago
WFM trunk linux ...
no answer -> goodbye bug
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 7

16 years ago
Yep, as one who has experienced this problem before, I can say that it is gone
in the recent builds. (mine is 1.1b)

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.