[Email]The whole Compose view will be enlarged for a short while when you relaunch Emial from homescreen.

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::System
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: Annabelle, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [2.5-aries-test-run-1])

Attachments

(3 attachments)

(Reporter)

Description

2 years ago
Created attachment 8647399 [details]
Bug log: logcat_0441.txt

[1.Description]:
[Aries][v2.5][Flame v2.5][Email] Return to homescreen after inputting an email address in To filed, and relaunch Email, the whole Compose view will be enlarged for a short while.
  Found time:04:41
 See attachment: logcat_0441.txt &Aries_kk_v2.5

[2.Testing Steps]: 
Premise: There is a email account loged in device.
1.Launch Email app -->Creat a new email
2.Tap in "To:"item a email adress
3.Relaunch Email again
4.Observe the email adress in "To" item

[3.Expected Result]: 
4.The adress  size always keep normal.

[4.Actual Result]: 
4.The whole Compose view will be enlarged for a short while, then becomes normal at once.

[5.Reproduction build]: 
Device: Flame KK 2.2 (Unaffected)
Build ID               20150812032504
Gaia Revision          102f1299e9eafe3760e1deb44d556b5c4f36b5af
Gaia Date              2015-08-06 20:46:56
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/9295034c0ee3
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150812.065135
Firmware Date          Wed Aug 12 06:51:47 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK 2.5 (Affected)
Build ID               20150812150204
Gaia Revision          52f3ea58df38e5427f6afeb636bc6ad01d24022f
Gaia Date              2015-08-12 16:40:43
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cf932fc931dcd19f425934db79bec641ebe2a8a9
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150812.182303
Firmware Date          Wed Aug 12 18:23:12 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5(Affected)
Build ID               20150811234258
Gaia Revision          c7875bbc8b32e7b95cc55c9690b03b140905d84d
Gaia Date              2015-08-11 18:18:36
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/d4f3a8a75577e4af2914a4e899ca2e724f9715c4
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150811.230622
Firmware Date          Tue Aug 11 23:06:29 UTC 2015
Bootloader             s1


[6.Reproduction Frequency]: 
occasionally Recurrence,4/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

2 years ago
Created attachment 8647400 [details]
Bug video: Aries_kk_v2.5.3gp
(Reporter)

Updated

2 years ago
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
(Reporter)

Updated

2 years ago
Keywords: regression

Comment 2

2 years ago
It is not a serious bug (UI defect), but the user experience would be better if we can improve it.
This is not something controlled by email, but rather the screenshotting down by the system app and how it animates in those screenshots. Either that, or a drawing bug with restoring the email app. So I am going to move this over to the system app to find a better final destination for the bug.
Component: Gaia::E-Mail → Gaia::System
I'm guessing this is related to CSS pixel density.  I don't see much in the way of animation, but it looks like everything is exactly twice the size it should be for a bit.
The bug can't be reproduced on latest build of Flame KK v2.5 and Aries KK v2.5 by the STR in comment 0, so colse this bug. If 

anyone can repro it, please reopen again. Thanks.

Actual results: The adress size always keep normal.
See attachments: Aries KK v2.5.3gp.
Reproduce rate: 0/10


Device: Aries KK 2.5(Unaffected)
Build ID               20150830210046
Gaia Revision          31e595f86f6bf159b3a9a46816a6ac00a55ca9f9
Gaia Date              2015-08-30 00:42:30
Gecko Revision         http://hg.mozilla.org/integration/fx-team/rev/2ad5077d86ba81b667de45ccc986dbd2ce633cc4
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150830.203030
Firmware Date          Sun Aug 30 20:30:38 UTC 2015
Firmware Version       v18D v4
Bootloader             s1

Device: Flame KK 2.5(Unaffected)
Build ID               20150830150218
Gaia Revision          31e595f86f6bf159b3a9a46816a6ac00a55ca9f9
Gaia Date              2015-08-30 00:42:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/2ad5077d86ba81b667de45ccc986dbd2ce633cc4
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150830.184031
Firmware Date          Sun Aug 30 18:40:47 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
Created attachment 8654783 [details]
Aries KK v2.5.3gp
QA Whiteboard: [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.