font-rendering / anti-aliasing problem since firefox 40

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: romain.dartigues, Unassigned)

Tracking

41 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20150821])

Attachments

(1 attachment)

Reporter

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150811185633

Steps to reproduce:

Updating to Firefox 40 or Firefox 40.1 (beta).

OS: Microsoft Windows 7 64b
Hardware: Intel 4 series internal chipset on Dell Optiplex 780


Actual results:

Since the update, some text became barely readable.

As a workaround, disabling "Use hardware acceleration when available" *seems* to solve the issue.

On attached screenshot, the problematic version is at the right, which is, on my screen, really hard to read.

Same issue affect co-workers.
Reporter

Updated

4 years ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
Reporter

Comment 1

4 years ago
Errata: actually the issue persist even after disabling the hardware acceleration when changing tabs; some are affected, others are not (using the same website to check).

Comment 2

4 years ago
I'm having the same issue. I ported all settings/addons to regular main release Firefox and the font was being rendered properly there. It's definitely an issue that's only popped up on the Aurora/Nightly branches thus far.

Comment 3

4 years ago
Update: Upon reverting to Windows 7 from Windows 10 the font rendering issue seems to be gone. I have a feeling this issue has something to do with ClearType and it's interaction with changes on Aurora and Nightly.
I cannot repro using Windows 7 64 bit.
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150820142145
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Whiteboard: [testday-20150821]
You need to log in before you can comment on or make changes to this bug.