[Ubuntu] Video driver is crashed by WebGl animation

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: vasilica.mihasca, Unassigned)

Tracking

({crash, regression})

Trunk
All
Linux
crash, regression
Points:
---

Firefox Tracking Flags

(firefox41 unaffected, firefox42+ wontfix, firefox43 affected, firefox44 affected, firefox45 affected, firefox-esr38 unaffected)

Details

(Whiteboard: [gfx-noted])

Reproducible on: Firefox 43.0a1, Firefox 42.0a2  under Ubuntu 

STR
1.Launch Firefox with clean profile.
2.Navigate to http://madebyevan.com/webgl-water/

ER
The animation is properly loaded.

AR
The display driver stops and recovers continuously while the browser becomes unresponsive.

Additional notes:
- This issue is reproducible on Firefox 43.0a1 (2015-08-12), Firefox 42.0a2 (2015-08-12) under Ubuntu 14.04 32-bit.
- This issue does not reproduce on Windows and Mac.
- It is also reproducible without e10s.
- Did not encountered this issue on Firefox 41 Beta 1.

Graphics:
+---------------------------------+-------------------------------------------+
| Adapter Description             | X.Org -- Gallium 0.4 on AMD RS780         |
|                                 | (DRM 2.36.0, LLVM 3.6.2)                  |
+---------------------------------+-------------------------------------------+
| Asynchronous Pan/Zoom           | none                                      |
+---------------------------------+-------------------------------------------+
| Device ID                       | Gallium 0.4 on AMD RS780                  |
|                                 | (DRM 2.36.0, LLVM 3.6.2)                  |
+---------------------------------+-------------------------------------------+
| Driver Version                  | 3.0 Mesa 11.0.0-devel                     |
|                                 | (git-1eaa29c 2015-08-10 trusty-oibaf-ppa) |
+---------------------------------+-------------------------------------------+
| GPU Accelerated Windows         | 0/1 Basic (OMTC)                          |
+---------------------------------+-------------------------------------------+
| Supports Hardware H264 Decoding | false                                     |
+---------------------------------+-------------------------------------------+
| Vendor ID                       | X.Org                                     |
+---------------------------------+-------------------------------------------+
| WebGL Renderer                  | X.Org -- Gallium 0.4 on AMD RS780         |
|                                 | (DRM 2.36.0, LLVM 3.6.2)                  |
+---------------------------------+-------------------------------------------+
| windowLayerManagerRemote        | true                                      |
+---------------------------------+-------------------------------------------+
| AzureCanvasBackend              | cairo                                     |
+---------------------------------+-------------------------------------------+
| AzureContentBackend             | cairo                                     |
+---------------------------------+-------------------------------------------+
| AzureFallbackCanvasBackend      | none                                      |
+---------------------------------+-------------------------------------------+
| AzureSkiaAccelerated            | 0                                         |
+---------------------------------+-------------------------------------------+
| CairoUseXRender                 | 1                                         |
+---------------------------------+-------------------------------------------+
Please find the regression window.
Flags: needinfo?(vasilica.mihasca)
Keywords: regression, regressionwindow-wanted
status-firefox41: --- → unaffected
[Tracking Requested - why for this release]: this is a regression in Firefox 42.
tracking-firefox42: --- → ?
I can't reproduce the issue on my linux laptops (no AMD card, though). I assume this is a combination of driver issues and whatever we do to share webgl textures with OMTC on linux. I wonder how this is affected by what Andrew is doing with webgl texture sharing on linux (I don't have the bug number handy).

Vasilica, could you enable the pref layers.acceleration.force-enabled and report how this affects the issue?
Whiteboard: [gfx-noted]
(In reply to Nicolas Silva [:nical] from comment #3)
> I can't reproduce the issue on my linux laptops (no AMD card, though). I
> assume this is a combination of driver issues and whatever we do to share
> webgl textures with OMTC on linux. I wonder how this is affected by what
> Andrew is doing with webgl texture sharing on linux (I don't have the bug
> number handy).

Currently we only do texture sharing with WebGL and GLX if the OpenGL compositor is being used (we readback into shmem otherwise). However, if GL layers was being used when this crash occurred, bug 1194472 is likely responsible.
I was unable to obtain a regression window because once the driver had crashed for a Firefox build, then it crashed for all builds, including Firefox 41 Beta 1.

I’ve tested back to Firefox 30.0a1 (2014-03-01) and the driver also crashed for this Firefox build.

Sometimes, loading the WebGl animation, it was displayed an error message “Error: Rendering to floating-point textures is required but not supported”. See screenshot: http://i.imgur.com/ZZbaOV0.png
Flags: needinfo?(vasilica.mihasca)
(In reply to Nicolas Silva [:nical] from comment #3)

> Vasilica, could you enable the pref layers.acceleration.force-enabled and
> report how this affects the issue?

I set layers.acceleration.force-enabled to true in Firefox 42.0a2 (2015-08-19) and Firefox 43.0a1 (2015-08-18): the video driver stopped and recovered one time and after that graphical glitches appeared in the animation section. See screenshot: http://i.imgur.com/U3o6rSm.png
Visual regression, tracking.
tracking-firefox42: ? → +

Updated

3 years ago
Keywords: crash
Has this been observed on more than one machine?
Not sure but besides this bug, I didn't see any other complaints.
Anyway, not tracking for 42 anymore.
status-firefox42: affected → wontfix
Are we still trying to track down the regression range on this?
Flags: needinfo?(vasilica.mihasca)
Unfortunately, Vasilica no longer has access to that specific AMD card machine; with latest Nightly 45.0a1, under Ubuntu 14.04 32-bit, the display driver stops and recovers continuously while the browser becomes unresponsive, but no video driver crash at the moment.

Graphics:
Adapter Description	X.Org -- Gallium 0.4 on AMD RS780
Asynchronous Pan/Zoom	wheel input enabled
Device ID	Gallium 0.4 on AMD RS780
Driver Version	3.0 Mesa 10.1.3
GPU Accelerated Windows	0/2 Basic (OMTC)
Supports Hardware H264 Decoding	No;
Vendor ID	X.Org
WebGL Renderer	X.Org -- Gallium 0.4 on AMD RS780
windowLayerManagerRemote	true
AzureCanvasBackend	cairo
AzureContentBackend	cairo
AzureFallbackCanvasBackend	none
AzureSkiaAccelerated	0
CairoUseXRender	1

Additional notes:
1. With 'layers.acceleration.force-enabled' pref set to true, it's slightly better and no graphical glitches (as mentioned in comment 6).
2. Regression range (m-c):
Last good revision: 0496b5b3e9ef (2015-06-05)
First bad revision: 4a07e1ac3cdf (2015-06-06)
Pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0496b5b3e9ef&tochange=4a07e1ac3cdf
Flags: needinfo?(vasilica.mihasca)
Were these builds too old for mozregression to continue bisection on inbound? I thought we had archived builds going back further than June.

Bug 1144906 looks like a possibility in that range (the bug title sorta-implies it being Windows-only, but it looks like it touched a lot of cross-platform code).
https://hg.mozilla.org/mozilla-central/rev/10f2a5e84c91

I don't see anything else that looks terribly likely. If we don't have inbound builds available, I can try spinning some builds locally to try out, though. Let me know.
Flags: needinfo?(alexandra.lucinet)
It could be useful to do a build just before bug 1144906 and just after; that's a large change, so narrowing down to that one bug would help a lot.
Managed to find the m-i regression range too:
Last good revision: c7720cbbe62ed6e3b56e0dafa794b94b720a0044
First bad revision: c4d1692d88ee675a949c325227324570c9c946aa
Pushlog: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c7720cbbe62ed6e3b56e0dafa794b94b720a0044&tochange=c4d1692d88ee675a949c325227324570c9c946aa

None of the test builds work for me - I get 'cannot execute binary file: Exec format error' in terminal; but I guess the m-i range is enough since bug 1144906 is the only one from the pushlog :) Let me know if I can help more!
Flags: needinfo?(alexandra.lucinet)
Keywords: regressionwindow-wanted
(In reply to Alexandra Lucinet, QA Mentor [:adalucinet] from comment #15)
> None of the test builds work for me - I get 'cannot execute binary file:
> Exec format error' in terminal;
ARGH
> but I guess the m-i range is enough since bug 1144906 is the only one
> from the pushlog :) Let me know if I can help more!
Woo, thanks :)
Blocks: 1144906
status-firefox44: --- → affected
status-firefox45: --- → affected
status-firefox-esr38: --- → unaffected
Flags: needinfo?(jgilbert)
Is this still a problem?
Flags: needinfo?(vasilica.mihasca)
(In reply to Milan Sreckovic [:milan] from comment #17)
> Is this still a problem?

This issue is no longer reproducible with 46.0b5 build 1 (Build ID: 20160324011246), latest Aurora 47.0a2 and Nightly 48.0a1 (from 2016-03-27), under Ubuntu 14.04 32-bit; although, on 46 beta some bad re-paintings are visible when the animation is paused and the sphere dragged around, along with some not very noticeable hangs - but no video crash.
Flags: needinfo?(vasilica.mihasca)
Let's reopen if it comes back.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
Flags: needinfo?(jgilbert)
You need to log in before you can comment on or make changes to this bug.