Closed Bug 1194247 Opened 4 years ago Closed 3 years ago

"sudo ./mach install" wants me to run mercurial-setup

Categories

(Firefox Build System :: Mach Core, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1277406

People

(Reporter: nounoursheureux, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20150812225404

Steps to reproduce:

Run ./mach install as a user who hasn't configured Mercurial.


Actual results:

Mach refused to install and asked me to run "./mach mercurial-setup".


Expected results:

Mach doesn't need a working Mercurial environment to install the build, so it should not ask me to run "./mach mercurial-setup". I found that I can fix this by adding the "install" command here: https://dxr.mozilla.org/mozilla-central/source/build/mach_bootstrap.py#246 . Is this a good solution ?
This was addressed in bug 1277406.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1277406
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.